Support » Plugin: WP-TopBar » Can't Edit TopBar Text

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Bob

    (@rfgoetz)

    I need a bit more details to solve your problem.

    Are you getting any errors in your JavaScript Console?

    What version of PHP are you running on?

    If you wish, I can log into your site and see if I can find the error.

    using jQuery v1.8.3

    Uncaught TypeError: Cannot read property ‘length’ of undefined load-scripts.php:2
    Uncaught TypeError: Object [object Object] has no method ‘sortable’ gallery_post.js:28

    These are the error messages. Unable to pull up the section where you edit the text that goes into the bar.

    Plugin Author Bob

    (@rfgoetz)

    Those scripts are not part of my plugin. Sounds like you have a problem with a different plugin or a corrupted 3.5 install.

    Have you tried reinstalling 3.5?

    What is your website? I may be able to see javascript errors from there to help debug.

    Bob

    Error only shows up at the admin panel not the actual site. Plugin works for the public but uneditable in the admin panel.

    Plugin Author Bob

    (@rfgoetz)

    From what I can tell, it looks like you have a jquery conflict. Did have some other plugin that tries to deregister jquery?

    wp_deregister_script(array('jquery'));

    You can try adding

    wp_enqueue_script('jquery');

    To wptb_enqueue_admin_scripts() in wp-topbar.php

    Let me know if that works.

    Bob

    Plugin Author Bob

    (@rfgoetz)

    Also, look at this thread: http://www.wpaustralia.org/topic/jquery-script-load-fail-on-wordpress-3-5/

    It may be a 3.5 bug.

    See if adding the following to your wp-config.php file resolves the issue.

    define('CONCATENATE_SCRIPTS', false);

    Again, let me know.

    I think it has to do w/ jQuery’s version used. My theme uses 1.6 jQury. Most likely have to either remove your topbar plugin or update my entire thing’s jquery to the latest.

    Apologize, issue has nothing to do with your plugin. It just happens your plugin breaks with this particular theme’s issues. Keep up the great work @rfgoetz sorry for the inconvenience. Is your plugin on GitHub? Will fork and hopefully help out. Once again sorry for the inconvenience.

    I think I found the problem. My site uses jQuery 1.8.3 and jQuery-UI 1.9.2 and I think top-bar uses jQuery-UI 1.8.16. Seem to be jquery 1.8.3 and jQuery-UI 1.8.16 conflict, but I can be wrong. What’s your thoughts?

    When I remove the plugin i get the following:

    Delete Plugins
    You are about to remove the following plugins:

    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by
    WP-TopBar by Bob Goetz
    Are you sure you wish to delete these files?

    When in my development site with the same theme, data, everything it works fine, but on production site, it won’t allow for editing topbar content.

    Plugin Author Bob

    (@rfgoetz)

    Regarding jquery, you can try putting jQuery 1.9.2 UI files in the /lib subfolder. Then change wp-topbar.php in wptb_enqueue_admin_scripts() to have the filenames of what you downloaded.

    On the delete side, I believe what you seeing is a side affect of how it is activated. I have not been able to replicate it to find out why it does that.

    Plugin Author Bob

    (@rfgoetz)

    Not sure if you are still using the plugin.

    I just uploaded v 4.11 and it now uses jQueiry 1.9.2.

    With backward compatibility? I downgraded your plugin to 3.xx and its so niceeeee, now.

    Plugin Author Bob

    (@rfgoetz)

    I am not sure what you mean by backward computability.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can't Edit TopBar Text’ is closed to new replies.