Support » Fixing WordPress » Cant change PHP

  • Hello all,

    I`ve recently changed servers and need to update the pages on my site, but each time i try to update the PHP is a post or page it will not update and either goes to a page saying this if i try updating or previewing page :

    This error (HTTP 501 Not Implemented or HTTP 505 Version Not Supported) means that the website you are visiting doesn’t currently have the ability to display the webpage, or support the HTTP version used to request the page.

    Or when i try to update it in a widget, the update circle will just spin for as long as i leave it..

    any suggestions? ive tried this 100s of times still the same outcome,

    tried deactivating all plug in`s still nothing.

    Thanks for any help

Viewing 15 replies - 1 through 15 (of 21 total)
  • esmi

    (@esmi)

    Forum Moderator

    Try contacting your hosts for assistance.

    Hi,

    I did contact them at the first hurdle but they said it must be a wordpress issue, although they didnt look into it for me and wernt helpfull at all…

    Any other suggestions??

    esmi

    (@esmi)

    Forum Moderator

    Have you:

    – switched to the Twenty Eleven theme to rule out any theme-specific problems?

    reset the plugins folder by FTP or PhpMyAdmin?

    Just both of them, still no change.

    Really frustraighting any other ideas??

    Thanks again for the help

    esmi

    (@esmi)

    Forum Moderator

    I’m sorry but it really does sound like a server issue – not a WordPress one.

    I rang the hosting company and they said that because wordpress is a 3rd party add on, they dont offer support for it…

    so i`ve asked them if it could be anything to do with the server or hosting and they said everything is fine and working as it should be.

    Dont know what else i can ask them?!??!??

    Who is the hosting company? Do they promise PHP5 and MySQL?

    Have you tried uploading a PHPinfo file?

    Just make a file with the following PHP:
    <?php phpinfo(); ?>
    save as phpinfo.php
    upload to your server’s web root
    go to yourdomain.com/phpinfo.php

    This will list all PHP info and may help you (and/or us or your host) solve the problem.

    esmi

    (@esmi)

    Forum Moderator

    Did you give them copies of the error messages?
    These are both clearly server issues
    http://www.checkupdown.com/status/E501.html
    http://www.checkupdown.com/status/E505.html

    If they continue to refuse to investigate further, start looking for a new hosting company. We can all do without bad hosts.

    The hosting company ive moved to is called xilo, ive rang 3 times today asking if they could help me out with my problem, they didnt even look it up just said it cant be anything to do with the hosting and WordPress is a 3 party so ask them to sort it out!!

    basically just blanked me no help what so ever, no support what so ever!!

    When i was with fasthosts, they would have looked and helped me sort the problem straight away, whilst on the phone!!

    I`ve tried to do as you said with the file you suggested and this is the responce i get :

    Warning: phpinfo() has been disabled for security reasons in /home/exercise/public_html/phpinfo.php on line 1

    Does this make sense???

    Thanks again for the help

    Run away. Switch hosts to a reputable one.

    Well stuck with them now, they are con artists, I was ringing them for a week with problems setting up my sites and they just palmed me off saying they couldnt understand what i was asking them!

    Then when i said right i want my money back and to cancel the hosting as i couldnt use it, they said its none refundable and said i can cancel but with no refund...joke...avoid at all costs…

    the very least they could do is sort this problem out..

    Any other ideas??

    esmi

    (@esmi)

    Forum Moderator

    Point them at this this thread and point out that they are now getting some very bad publicity.

    Do you have cPanel access? Can you check there if PHP is in fact running? If it’s PHP5?
    Is your site visible at all? Just admin pages are the problem?
    What’s the URL?

    Yes i have cpanel access, Not sure how to check if its running or what version it is tho????

    The site is up and running http://www.exercisesupplies.co.uk My problem is i cannot edit any pages and none of the PHP is working.

    Thanks again for any help

    Ah, well one problem is that the plugin exec-php is throwing errors:
    http://www.exercisesupplies.co.uk/tag/boxing-gloves/
    Warning: require() [function.require]: open_basedir restriction in effect. File(/home/fhlinux008/e/exercisesupplies.co.uk/user/htdocs/comparison/external.php) is not within the allowed path(s): (/home/exercise:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/exercise/public_html/wp-content/plugins/exec-php/includes/runtime.php(42) : eval()’d code on line 2

    So the PHP that isn’t working is what you’re injecting on pages/posts?

    I don’t know this plugin but it looks like the root of your problem is there. Try opening a ticket in the forums for the Exec-PHP plugin. The people who use it may know better than some of us.

    And it never hurts to re-upload the plugin fresh, to ensure it’s uploaded properly.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Cant change PHP’ is closed to new replies.