Support » Plugin: WooCommerce » Can't add variable products to cart

  • Resolved think.different

    (@thinkdifferent-1)


    I am running a Multisite install of WP

    I can add simple products but not a variable product, I can choose a variable, I can click Add to Cart, I get the “successfully added to your cart.” message, but the cart is still empty.

    I have tried the following without success:
    – Updated to latest version 2.3.8
    – downgraded to 2.8.11
    – Console has no .js errors
    – Switched to Twenty Fifteen
    – My theme doesn’t use a custom /single-product/add-to-cart/variable.php file, it is using the bundled one
    – tried woocommerce-jquery-cookie-fix.zip
    – Deactivated all plugin bar WooCommerce
    – Change php version from 5.2 to 5.4

    In the short term I have change all the products from variable to simple so the site can go live, but not ideal.

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author royho

    (@royho)

    There could be different causes to this issue however please note WooCommerce doesn’t work with multisite. So you would need to activate WooCommerce per site level and not network level for it to work.

    It is only added to one of the sites, which is a dedicated store.

    Now I’m getting an extra issue. The simple products are added to the cart – I can see them in the cart widget. But when I View Cart or click Checkout – it’s empty. But if I click to any other page the Cart Widget still shows that it’s not empty.

    Plugin Author royho

    (@royho)

    Check if you have any caching whether server side or site level…Disable it temporarily and re-test.

    Once you login you can then see the carts contents. Guests only see an empty cart.

    I read https://wordpress.org/support/topic/empty-cart-for-guest-users-permalinks-issues?replies=3

    They mention Permalinks so I thought I’d check them. I have reset them now and now WIN IE, MAC FF/S/C and iPhone working. But WIN FF/C & iPad not working. I guess this will be down to cache.

    I also made one of my variable products live again and this seems to be working (checked in Win IE & MAC Safari).

    I have no cache plugin – how would I check server side?

    Plugin Author royho

    (@royho)

    Contact your hosting company to ask about cache on their end.

    Just sent them a support ticket.

    Others have suggested:

    1) php sessions not enabled serverside
    2) change your php from suphp to mod_php

    Still waiting to hear back from hosting company….

    But I found this:
    http://businessbloomer.com/woocommerce-solving-cart-empty-issue/

    If I clear these AND have WooCommerce >Settings >Products > Display
    “Enable AJAX add to cart buttons on archives” UNCHECKED, it works BUT the cart widget doesn’t update. If I leave it Checked the widget works but the Cart does not.

    So I have removed the Cart widget and replace with just a Cart and Checkout Buttons.

    Next issue.

    After I click Checkout, I see the normal checkout page for a few seconds then it is replace with the message:

    “Sorry, your session has expired. Return to homepage”

    If I go back to the Cart all is still there.

    Works correctly is you are not a Guest.

    I have now gone home from work and tested it on my mac there and all works – I was able to get to the credit card details page with out any errors, so it does look like some sort of cache issue.

    Still waiting to hear back to my support ticket with my hosting company….

    This is the response I got from the hosting company:

    This wouldn’t be anything server side preventing this but the following error is being produced :

    (site URL) [Fri May 01 22:04:59 2015] [error] [client 1(IP ADDRESS):55508] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

    It may be that the steps you are taking is causing it to go beyond this, you can either increase this via a php.ini file or find the cause and resolve it.

    Anyone know what this means?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Can't add variable products to cart’ is closed to new replies.