Support » Plugins and Hacks » [Resolved] Can't add or update

[Resolved] Can't add or update

  • I’m using this plug-in on an older site, and yesterday we noticed that we couldn’t update any GCBs or add new ones, despite the plug-in saying it had.

    The first thing I did was update the plug-in. No change.

    I then updated WordPress from 3.2.1 (I think) to the latest. No change.

    I then created a new site with a fresh install of WP and added the latest GCB. Works fine. Hmmm.

    On the problematic site, I’ve updated other plug-ins and that hasn’t helped.

    Further to this, I exported the GCBs from the problematic site and imported them into the new site to check that they weren’t the problem. They worked fine, but I noticed that their IDs had completely changed. For example, ID 459 had become 259. This would be a real problem had I have removed them from the problematic site and re-imported them.


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author benz1


    We are unable to replicate this issue but my developer is trying to find the problem. Will release an update when resolved.

    Thanks for looking into it. I can give you access to the site so you can see for yourself if that helps – maybe you can see something obvious from the output in Firebug or something similar?

    Plugin Author benz1


    Apologies for the delay. My developer thinks the issue only occured when updating from an old version and has simplified the code. He thinks it should resolve the issue but would be good if you could test first before I update on the repository.

    You can download the updated version from benz1.com/temp/global-content-blocks-1-5-7-beta.zip and replace your existing version. Can you please let me know if this resolves the issue for you?


    Thanks! This has resolved the problem.

    I have been able to add new blocks and update existing ones.

    Many thanks!

    Plugin Author benz1


    Cool, thanks for testing. I’ll update it on the repository later today.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Can't add or update’ is closed to new replies.