Support » Plugin: FoxyShop » Cannot use object of type WP_Error as array in adminfunctions.php

  • Resolved jurassicfrog

    (@jurassicfrog)


    Hey, anyone run into any issues saving the setting upon install? When I put a foxycart domain in and attempt to save I’m getting the following:

    ( ! ) Fatal error: Cannot use object of type WP_Error as array in C:\wamp\www\devsite\wp-content\plugins\foxyshop\adminfunctions.php on line 614
    Call Stack
    # Time Memory Function Location
    1 0.0011 344136 {main}( ) ..\options.php:0
    2 0.0021 411512 require_once( ‘C:\wamp\www\devshop\wp-admin\admin.php’ ) ..\options.php:19
    3 0.2685 21549736 do_action( ) ..\admin.php:109
    4 0.2730 21730912 call_user_func_array ( ) ..\plugin.php:406
    5 0.2730 21730944 foxyshop_save_settings( ) ..\plugin.php:406
    6 0.2735 21733840 foxyshop_get_foxycart_data( ) ..\settings-page.php:101

    I am developing on WAMP so it’s localhost but I didn’t think that’d be an issue for anything but the datafeed. Ideas?

    Thanks!

    http://wordpress.org/plugins/foxyshop/

Viewing 7 replies - 1 through 7 (of 7 total)
  • I received that same Fatal error, however I was not saving the same field. I was updating the Cart Cache.

    – Tools / Misc Tools / Update FoxyCart Template / Update Cart Cache

    The issue didn’t persist so I’m not sure where it came from. Thought I’d confirm that I’ve seen it too.

    Plugin Author sparkweb

    (@sparkweb)

    I’m aware of the issue. I will be getting a fix pushed out on this. This is indicative that there was a cURL error. Often this has to do with SSL peer verification failing which you can fix by setting a flag in wp-config or installing the cert files for FoxyCart’s SSL provider.

    Sorry about the trouble. I’ll get a more permanent fix posted soon.

    Plugin Author sparkweb

    (@sparkweb)

    I just pushed up 4.4.1 which should resolve the WP_Error issue.

    Thanks! Will let you know if I see it again, and will try to provide more info if I do. Great work on this btw there’s a lot of code in here!

    Awesome! Thank you kind sir.

    I am having an issue when attempting to log into my dashboard! And I can not update more change any information from my account.

    Can anyone help me with this issue?

    Error Message:

    Fatal error: Cannot use object of type WP_Error as array in /home/content/p3nexnas05_data02/77/2130877/html/wp-content/plugins/spatialtree/common/api.php on line 116

    Plugin Author sparkweb

    (@sparkweb)

    Hi, I think I’d probably check with the spatialtree plugin folks about this. They may be able to help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot use object of type WP_Error as array in adminfunctions.php’ is closed to new replies.