Support » Plugin: VK Blocks » Cannot update

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor kurudrive

    (@kurudrive)

    こちらで確認する限り問題なくアップデートできますが、どういう状況でしょうか?

    Thread Starter drumsuko

    (@masatouehara)

    「プラグインの更新」にいて、VK Blocks 1.20.7 を 1.21.0 に更新しようとすると、メンテナンス中のまま戻って来ません。

    Thread Starter drumsuko

    (@masatouehara)

    複数のサイトで同じ状況です。「.maintenance」を削除するしか解決方法はありません。どうぞよろしくお願いいたします。

    Plugin Contributor kurudrive

    (@kurudrive)

    こちらの環境で再度いくつか確認する限りは問題なくアップデート完了しました。
    (通常のプラグインよりデータ量が多いのでアップデート完了まで若干時間がかかります)

    考えられる要因としては以下になります。

    * drumsuko さんのご利用の環境で不具合が発生する
    * アップデートの途中で別のページに移動したりページの再読み込みをした
    * 配信サーバーあるいは通信状況の都合で更新が失敗した

    ご利用のWordPressのバージョンとサーバーのPHPのバージョンはいくつでしょうか?

    「複数のサイトで同じ状況」との事ですがサーバー会社は別々でしょうか?
    同一サーバー内に複数置いてある状態でしょうか?

    Thread Starter drumsuko

    (@masatouehara)

    ご確認、どうもありがとうございます。
    * drumsuko さんのご利用の環境で不具合が発生する
    =>この可能性はありますが、他のプラグインは問題無く更新できております。
    * アップデートの途中で別のページに移動したりページの再読み込みをした
    =>アップデートの途中で別のページに移動したりページの再読み込みはしておりません。
    * 配信サーバーあるいは通信状況の都合で更新が失敗した
    =>タイムアウトの可能性はありますが、他のプラグインは問題ございません。

    WordPressのバージョン;5.8.3
    サーバーのPHPのバージョン:PHP7.4.2
    サーバーの会社は全て「お名前.com」ですが、全て別サーバです。

    VK Blocksの更新も今までは問題が無かったので、バージョン1.21.0 に問題があると考えております。
    どうぞよろしくお願いいたします。

    Plugin Contributor kurudrive

    (@kurudrive)

    今までの情報からすると、ご利用のプラグインのどれかと干渉するのかなと思います。

    まずどれか一つのサイトでアップデートではなく削除・再インストールして有効化はできますか?

    Thread Starter drumsuko

    (@masatouehara)

    kurudriveさま
    ご対応いただき、誠にありがとうございます。
    削除して再インストールを試みましたが、残念ながらインストールが出来ませんでした。「更新に失敗しました」と表示されます。
    他のプラグインとの干渉が原因なのですね、VK Blocksを疑って申し訳ございませんでした。
    しばらく様子を見ようと思います。
    PHPのバージョンも上げてみようと思います。

    Plugin Contributor kurudrive

    (@kurudrive)

    あ、いえ、 VK Blocks が何か問題がある可能性は全然消えたわけではありません。

    新規インストールで「更新に失敗しました」が表示されるという事は
    何かが原因で新規インストールになっていないのかなと思います。

    .maintenance が削除されている状態で VK Blocks を完全に削除・新規インストール(最新版を直接インストール)・有効化 してみてください。
    1.21.0 が他のプラグインとの干渉が原因でアップデートに失敗している場合は、上記手順で有効化しようとするとでエラーが表示されて、有効化出来ない状態になると思います。

    とりあえず改めて上記でどんな症状になるかお試しください。

    VK Blocks 単独で新規インストール・有効化 が出来る場合は、
    プラグインのプログラムの不具合というよりも、古い(既存)バージョンのファイルを削除したりする権限などの問題も考えられます。
    ※ VK Blocks 内特定の拡張子などのファイルが お名前サーバーではファイルのパーミッションが自動的に削除処理不可に割り振られてしまって削除・更新ができないなど

    Thread Starter drumsuko

    (@masatouehara)

    .maintenance が削除されている状態で VK Blocks をフォルダごと完全に削除し、新規インストールを試みましたが、「インストール中」がしばらく続いた後、前回と同様、「更新に失敗しました」となりインストールできませんでした。

    Plugin Contributor kurudrive

    (@kurudrive)

    こちらで再現しないので以下から該当サイトのログイン情報を送付いただくか、

    https://vws.vektor-inc.co.jp/contact/inquiry2

    all in one wp migration で出力したデータをどこかにアップしてダウンロードURLをご連絡いただければ、直接確認はさせていただきます。

    Thread Starter drumsuko

    (@masatouehara)

    誠に申し訳ございませんが、ログイン情報の共有は不可となります。
    問題が起きているのが私だけの環境であれば、これ以上お手数をお掛けするのは申し訳ないので、しばらく様子を見ることにします。
    PHPのバージョンを上げてみたり、他のプラグインを一時的に止めたりしてみます。

    kurudriveさまのご親切な対応に心から感謝いたします。

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cannot update’ is closed to new replies.