Support » Fixing WordPress » Cannot resize images (no option)

  • Resolved svsdnb

    (@svsdnb)


    When I go to upload and use an image I only have the option to use the “Large” image. There’s no resize options. I’m not using any additional plugins to hinder this, at least to my knowledge. Could this be a permissions issue with the uploads folder?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I am having the same problem. I built the site on a development server, where everything worked perfectly, then transferred it to the live server and the only size I can select for uploaded images is full size. I’ve checked and double checked permissions on each server for comparison, and there is no difference.

    The image me be re-sized appropriately already and the choices mentioned are not available. E.g., 145px X 145px. The size is smaller than thumbnail so it won’t be available. Make sense?

    Jeremy Clark

    (@jeremyclark13)

    Member

    Your server might not have GD support which is needed for php to resize images. Check with your host.

    @jeremyclark13
    Thanks, I just noticed that and fixed it right before I came here. All is working properly now. Thanks for being fast on the response!

    Jeremy Clark

    (@jeremyclark13)

    Member

    Glad you got it figured out.

    Just for newbies, PHP 5.2.x has built in GD support, but you have to un-comment the “;extension=php_gd2.dll” line by removing the “;” from the beginning of the line. Save, restart your web server services (you have to restart IIS – unsure about Apache), and you’re in business.

    You will have to re-upload the images which you uploaded prior to making this change in order for WordPress to create thumbnails for them.

    If you do not own your webserver, this will have to be done by your hosting company – if they are willing.

    The server didn’t have GD or anything installed.

    DOH!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot resize images (no option)’ is closed to new replies.