Support » Fixing WordPress » Cannot post XML CDATA

  • Resolved dandago

    (@dandago)


    I run a blog for developers. Today I had an issue with WordPress redirecting to the homepage whenever I tried to post something. Following advice on other threads, I tried disabling themes, plugins, permalink settings, etc until I narrowed it down to a piece of XML CData which WordPress apparently doesn’t like (note that I’m using SyntaxHighlighter Evolved):

    [xml highlight="8-18"]
      <akka>
        <hocon>
          <![CDATA[
            akka
            {
              loglevel = DEBUG
    
              actor
              {
                debug
                {
                  receive = on      # log any received message
                  autoreceive = on  # log automatically received messages, e.g. PoisonPill
                  lifecycle = on    # log actor lifecycle changes
                  event-stream = on # log subscription changes for Akka.NET event stream
                  unhandled = on    # log unhandled messages sent to actors
                }
              }
            }
          ]]>
        </hocon>
      </akka>
    [/xml]

    Removing the CDATA section, the post goes through without any problems.

    Why is WordPress preventing me from posting this, and is there any workaround to go ahead and post it anyway?

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cannot post XML CDATA’ is closed to new replies.