Support » Plugin: WooCommerce » Cannot load wc-reports – URL issue

  • Resolved webyseo

    (@webyseo)


    Hi,

    I want to create a custom report and in all cases the error message “Can not load wc-reports” appears.

    I have noticed that the URL generated in this site is different from the URL generated in another store where the custom report works correctly.

    URL where the report fails:

    ../wp-admin/admin.php?page=wc-reports&post_type=post&range=custom&start_date=2019-07-01&end_date=2019-07-07&wc_reports_nonce=8da2046310

    URL where the report works:

    ../wp-admin/admin.php?page=wc-reports&range=custom&start_date=2019-07-01&end_date=2019-07-07&wc_reports_nonce=8da2046310

    Why does “post_type=post” appear in the URL that the report fails? If I delete this part and charge again the report works … any suggestions?

    Best

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Three Sons

    (@3sonsdevelopment)

    Hi @webyseo,

    That is an unusual situation. Have you tried troubleshooting the code on this misbehaving site by temporarily disabling all plugins except for WooCommerce to see if it works correctly then?

    When I run a report with custom dates on my stores, it does not insert post_type=post into the URLs. Since it doesn’t do this on the other site of yours either, the best way to find out why it’s happening here is to start with a conflict test like this.

    If the custom reports work with the plugins disabled, you can add start turning them back on, testing as you go until they stop working again. That will point to the source of the conflict.

    Let me know what you find out and we’ll go from there.

    Best,

    Plugin Support Three Sons

    (@3sonsdevelopment)

    Hi @webyseo,

    It’s been a while since we heard from you, so I’m marking this thread resolved. Hopefully, you’ve been able to resolve this, but if you haven’t, please let open up a new topic and we’ll be happy to help out.

    Cheers,

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.