Support » Plugin: mqTranslate » Cannot insert images in text editor

  • Resolved madvgr


    Hello there

    Search the support forums but i can’t find a solution to my problem.

    Using text editor i cannot insert an image in a post/page. Visual editor works fine… In text editor the media window pops up, i can select the image i want, but when i click “insert”, nothing happens… (returns to post with no changes)

    I disable mqtranslate and text editor worked fine…

    Any idea?

    Thanks in advance

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author chsxf



    I just tried the bug you’re reporting and, indeed, it does not work correctly.
    In fact, it has a strange behavior. During my tests, image has been added to another language than the active one. Very strange.

    We will dig into it as soon as possible.

    Thanks for the fast answer and keep on the good work 😉

    Same problem here. Image is either not inserted at all, or inserted for another language. Any clues yet? Thank you in advance.

    Same problem here as well, and it is pretty annoying. Any chances for a fix in foreseeable future?

    I can insert images, but I cannot embed videos. Every time after saving the iframe disappears.
    (I posted this before in a [resolved] topic, so I put it here again.)

    I have the same issue, when i post an image in TEXT mode the image is posted on the other language tab, not the one selected.

    I have the same but only for non admins in page and post
    It works fine trough multimedia. I noticed that the expand buttons doesnt work either (screen options, main menu etc)
    maybe is a jquery conflict

    I have the same problem: every time I try to insert an image, the code is added into the tab of another language.
    This is very frustrating.

    I hope it will be fixed asap! Thanks

    When is this bug going to be fixed?

    same problem, very hard for not admins to embed videos in the txt tab.

    help please!! 🙂

    I have same problem. Image in TEXT mode is posted on the other language tab….

    Would be interesting to here if/when this bug will be fixed. It is known since 6 month… This starts being a dead repo like qtranslate… Just some communication would be nice…

    Best regards and thanks for the work!

    Is this problem so difficult? I turned off all other plugin, but this problem is exist.I hope it’ll be fixed!

    Plugin Author chsxf


    I’m glad to announce that a fix will be released in the next update of mqTranslate.

    Version 2.9: “Fixed mislocation of inserted media in the wrong languages when using the text editor.”

    I can confirm that this error is not fixed in version 2.9

    The problem still exists when calling the send_to_editor function.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Cannot insert images in text editor’ is closed to new replies.