WordPress.org

Support

Support » How-To and Troubleshooting » Cannot create thumbnails

Cannot create thumbnails

  • I am not able to create thumbnails when uploading images to WP. Here is my configuration:

    Fedora Core 4
    Apache 2.0.54 (rpm)
    PHP 5.0.4 (rpm) with php-devel, php-gd, php-mysql, php-pear, php-ldap, and php-mbstring
    GD 2.0.33 (rpm) with gd-devel

    When I first installed WP, I would get the error “Filetype not supported. Thumbnail not created.” whenever I tried to create a thumbnail. After reading the message boards, I realized I needed gd support for php. I then installed the php-gd rpm. I checked my phpinfo and now I have gd support enabled.

    Now when I try to create a thumbnail, instead of getting the “Filetype not supported” error, I get no output at all. The page is still there with the css and the options across the top, but the text box that usually tells you your image was uploaded is completely empty. I tried uninstalling php-gd, and the “Filetype not supported” error came back. I reinstalled php-gd, and the box was empty again.

    Please help!

Viewing 1 replies (of 1 total)
  • I figured it out on my own. First off, if you get “Filetype not supported,” you need GD support for php. If you installed php from rpm, you need to install the php-gd rpm as well. If you installed from source, you need to recompile with GD support.
    As far as the blank page after installing gd, I checked the httpd error log and saw this:
    PHP Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 12000 bytes)
    I had to edit my /etc/php.ini file and increase the memory_limit variable to 24M. Now it works!

Viewing 1 replies (of 1 total)
  • The topic ‘Cannot create thumbnails’ is closed to new replies.