• Resolved Peter Smits

    (@psmits1567)


    Hi

    After one of the last updates I get the following error when I open an existing email
    Entity of type ‘MailPoet\Entities\NewsletterEntity’ for IDs id(0) was not found
    It is rather urgent for me, does anyone have the same
    Please advise.
    Peter

Viewing 8 replies - 1 through 8 (of 8 total)
  • Peter Smits

    (@psmits1567)

    Some extra information about this issue
    I have concepts that indicate “wrong date”
    I have had a problem with installing updates mailpoet
    Indication a problem with date conversion
    I think this is related to this issue !

    Peter Smits

    (@psmits1567)

    A new update after some investigations
    Within the tabel mail_poet_newsletters a field ‘parent_id’ exists
    Some of the records had a value of ‘0’
    Others had a value “NULL”
    So I altered one of the not working emails to have value ‘NULL’
    After that I could open the newsletter again !
    But for one other record I got as a result “Syntax error”
    I do not know what went wrong, but defenitely an update has caused this

    Plugin Author MailPoet

    (@wysija)

    Hi there @psmits1567,

    Can you let us know if you’ve recently deleted or moved to trash a newsletter list?

    And the newsletter you get this error on, is it a standard newsletter? A welcome email or post notification?

    Thanks!

    Hi

    No I did not delete newsletters nor newsletter lists.
    The syntax error I currently get, is on a newsletter we created in the past. The syntax error is generated on one of the newsletters containing the “0” value within the parent field which I aletered to Null

    When should this field contain a value?
    In the past we copied an existing newsletter and modified that, so we could sent it as a new newsletter. If I create a new from scratch the problem does not exist, so it appears that a conversion problem exists.

    I more or less had the same problem with the subscribers after importing them. They all got a value “0” in the wordpress user field. You cannot delete such a subscriber. I already indicated that a fix should be applied to solve that. There are more users that reported not being able to delete subscribers.
    Thanks for your help!

    I am having this same problem, I am looking for a resolution also. Same thing, I get the error on past newsletters as well as newsletters that are duplicated from past newsletters, but if I create a new newsletter then I do not have a problem.

    Plugin Author MailPoet

    (@wysija)

    Hi there!

    This has been fixed with the latest update. If the issue persists at all, please let us know. 🙂

    Thanks!

    Hi

    Thanks for solving the issue, it is no longer present after installing the new version !

    Regards,
    Peter

    Awesome, this is fixed for me too, thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.