WordPress.org

Support

Support » Themes and Templates » calendar problem

calendar problem

  • My calendar has some issues currently. I just added it, and instead of explaining what’s wrong, take a look: http://mandyanne.dkmhosting.com/wordpress

    What’s wrong (in case you can’t really tell) is that the day for sept. 2nd was made into a link because I posted that day, but the link is too long, making the table unproportioned. I want my other links to stay as they are in the other places (categories, for example), but I do not want the hover image (the diamond) within my calendar. Here’s the code for the calendar part:

  • <h2><?php _e(‘Calendar’); ?></h2>
    <?php get_calendar(‘1’); ?>
  • Please help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • definitially a css issue…

    ok, so do you have any idea how to go about fixing it? Or, to use an internal style sheet to override the external one just for the calendar section?

    i really don’t now too much stuff about css, everything i do with it is with trial and error…someone here will be able to help you no doubt

    ok thanks for the help anyway. Any new takers on my problem?

    You have a couple of CSS errors which should be cleaned up. This should be done first. It doesn’t look like there is any specific calendar settings in the CSS.

    Alright, can you be more specific? And what would the code be to set up the calendar settings in css?

    I only know enough CSS to be dangerous. In your style sheet, you have:

    #sidebar a {
    display: block;
    padding: 2px;
    width: 160px;
    padding-left: 12px;
    border-bottom: 1px solid #fff4df;
    background-image: url(images/icon1.gif);
    background-repeat: no-repeat;
    background-position: 0 55%;
    color: #39335B;
    text-decoration: none;
    }

    #sidebar a:hover {
    display: block;
    padding: 2px;
    width: 160px;
    padding-left: 12px;
    border-bottom: 1px solid #fff4df;
    background-image: url(images/icon2.gif);
    background-repeat: no-repeat;
    background-position: 0 55%;
    background-color: #cfc2a8;
    color: #39335B;
    text-decoration: none;
    }

    I’m guessing it has something to do with the image it places there. But maybe the person who helped you with the mod to the theme could better help you.

    I would see what the gif looks like and see its size. Maybe you could remove the line of code in the style sheet that refers to the gif file and see what that does.

    The problem is not with the calendar, it is with how you have set links in the sidebar – width:160px. Just remove that (or put it with #sidebar { } if you haven’t set the width).

    Ok I deleted the width lines in sidebar a and sidebar hover. That helped, but it still looks a bit odd.I think I’ll live with it though. Thanks.

    mandyanne, set the preferences here so the link points to your blog – not a splash page or some other page where we have to hunt for your blog. It will help you in the long run.

    As for the calendar. It will display “out of the box” but comes with lots of classes and ids to style how you wish, like:

    #wp-calendar td.pad {
    background: #CCBE92;
    }

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘calendar problem’ is closed to new replies.
Skip to toolbar