Support » Plugin: Better WordPress Minify » Cache-control headers

  • Resolved madmaxau

    (@madmaxau)


    Hi,

    THanks for the great plugin. I have a question about setting cache-control headers on minified scripts and css.

    I have set them via .htaccess and it seems to work on all my files except the minified ones. I can’t figure out why and i don’t want to alter your plugin. Do you have any idea why this might be happening?

    thanks,

    Max

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hey, I have the same issue when testing my site’s performance with GTmetrix.

    Only the files created by bwp-minify don’t seem to have expire headers…

    There are 7 static components without a far-future expiration date.
    
    https://mysite.net/wp-content/plugins/bwp-minify/cache/minify-b1-jquery-core-88f94ec63a51adc9be420752df2b598a.js?ver=1474644992
    https://mysite.net/wp-content/plugins/bwp-minify/cache/minify-b1-jquery-migrate-6cfda68c596c47506e1bb0ac13e3292e.js?ver=1474644992
    https://mysite.net/wp-content/plugins/bwp-minify/cache/minify-b1-jquery-ui-core-dd330a7271bac1c94df557b6adc9d282.js?ver=1474644992
    • This reply was modified 3 years, 1 month ago by Swennet.
    Plugin Author Khang Minh

    (@oddoneout)

    Please try to disable cache buster or using a fixed one. It seems that you’re using the last modified timestamp of the cache directory.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cache-control headers’ is closed to new replies.