Support » Plugin: qTranslate X » Bulk remove language

  • Resolved sous.studio

    (@sousstudio)



    Hey!

    First, thanks a lot for another reincarnation of this great plugin! That job you do is invaluable! Thank you!

    Second, I have a problem: when I added articles (imported, that is) and install qTranslate X, they got 2 languages each, naturally having the same content of just one language. I’d like to remove second language from posts, so they wouldn’t get displayed unless translated. Anyway to do except writing my own script?

    Thanks!

    https://wordpress.org/plugins/qtranslate-x/

    UPDATE: Tried /wp-admin/options-general.php?page=qtranslate-x&markdefault=true , which apparently removed ALL content from ALL posts & pages… 🙁

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Gunu

    (@grafcom)

    @sous.studio,

    naturally having the same content of just one language.

    Adding a new language is not automatically filled with the content of a another language.

    You will get a new blank field for the new language.

    when I added articles (imported, that is)

    Perhaps this is the problem, imported from ?

    @gunu,

    It doesn’t seem so. I’ve imported posts. I’ve checked that they have no qTranslate tags whatsoever (eg. single language). Then, when I enable second language in qTranslate X settings, what I get?

    1) in All posts, every posts gets this new second language automatically
    2) if I press Edit post, I get the same content on 2 languages.

    What am I missing?

    Plugin Author Gunu

    (@grafcom)

    What am I missing?

    You miss nothing, you have too much! 🙂

    When you create a new post and put in one language text, then this comes not also in the other language?

    Check this out, so you’ll know whether it has to do with import posts

    @gunu,

    Okay. It happens exactly like you said: new post in 1 language does not create new post in another language automatically.

    But I don’t have any tags in my other posts! Atleast I don’t see them. Perhaps this info is stored elsewhere?

    On the other hand, if I enable completely new language (that I know for sure was never used on my website) – it still automatically adds to all previously imported posts (except created manually).

    So, back to point A: how do I bulkly remove all language associations (except 1 maybe) from imported posts?

    Plugin Author Gunu

    (@grafcom)

    @sous.studio,

    when I came across something I would do it in the database.

    A database delete-query function. Information about this can be found on the internet I think.

    But imported post, from where – existing post you do not have to import anyway right?

    @gunu, I’m watching database right now. There are couple of posts with tags, but most posts are without. So, basically, yes, I know how to remove it manually from database, but I don’t see what to remove exactly. Does qTranslate stores some meta in wp_postmeta maybe?

    Posts are imported from old website (the one with old design, I’m switching it to new theme on test site).

    Plugin Author Gunu

    (@grafcom)

    @sous.studio,

    you could also try, install qTranslate on your old website with the same languages. If it is necessary, use – Convert Database –

    If you have installed qTranslate for the first time on a WordPress with existing posts, you can either go through all your posts manually and save them in the correct language or click here to mark all existing posts as written in the default language.

    You will not have to do anything further to the posts.

    Export the posts with the “more languages” see if that works.

    @gunu,

    Ahm, I’ve tried clicking there:

    “UPDATE: Tried /wp-admin/options-general.php?page=qtranslate-x&markdefault=true , which apparently removed ALL content from ALL posts & pages… 🙁 “

    It actually removed all content – both titles and body text, leaving only featured images and posts itself.

    Plugin Author Gunu

    (@grafcom)

    This happened in your old site?

    Huh? Are you lost everything?

    Nope, this happened on a new test site. And yes, it caused all content to be lost (a week of work + all imported posts).

    Plugin Author Gunu

    (@grafcom)

    I hope you read this also:

    Both processes are irreversible! Be sure to make a full database backup before clicking one of the links.

    But what I do not understand, why did you do that in your new site?

    you could also try, install qTranslate on your old website with the same languages. If it is necessary, use – Convert Database –

    Well, that was my mistake (not backing up, expecting the technology will work as expected).

    Because the general idea: take all posts & pages from the old site and export it; import the files (I exported posts and pages separately) to the new site; since language glitch is present, try to “Mark all content as written in default language”.

    Seems logical, isn’t it? Old site to be freezed as-is, while new site gets old’s content, to be marked as single language, and then, translate whatever is possible in future. But clicking that button nuked the content, instead of marking it as a single language.

    So, now I’m at the crossroads:
    1) Re-import data from old site again; Do 2 separate categories for two separate languages (since I cannot make posts of one language only except manually, which will take too much time).
    2) Write my own script that will somehow remove other languages association (I don’t understand yet where its stored, if not in post title/body).
    3) Try my luck with WPML (which I really don’t want to do, due to its high costs and complex work).

    😕

    Plugin Author Gunu

    (@grafcom)

    Ok, I try it step by step.

    Your old site is in one language?
    This is the default language in the new site?

    Two options if you still have to start again, but first is this correct?

    Is your new site now empty?

    My old site is 100% in one language, I believe. There are posts, however, that have <!–:ru–>content<!–:–> in their body, yet the content remains in same language.

    This is the default language in the new site.

    I’m all ears! 🙂

    Yes, my site now is empty.

    Plugin Author Gunu

    (@grafcom)

    First make backups so you can return…. 🙂

    There are posts, however, that have <!–:ru–>content<!–:–>

    Delete all codes <!–:ru–> and <!–:–> in the database of the old site so it is clean.

    If there are no pages and posts in the new site deactivate qTranslate X.

    Then your new site is also in one language (make sure it matches the old site)

    Export post and pages from your old site en import in the new site.

    You new site is one language so you should not get a duplicate content there – right?

    When all done then activate qTranslate X

    See if this works for you.

    Good luck!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Bulk remove language’ is closed to new replies.