Support » Plugin: Post Volume Stats » Bugs

  • Plugin Author shortdark

    (@shortdark)


    I thought it might be a good idea to have a bugs thread so that anyone can post in here if something is not working.

    To begin with, two I’m aware of are…

    * “Years” bar chart widget.
    * Words per Post: trim excess empty fields.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author shortdark

    (@shortdark)

    These should be fixed in 3.1.07. Any bugs please post here. thank you.

    Plugin Author shortdark

    (@shortdark)

    Bugs…

    * Some of the line graphs don’t have axes.
    * The “year” bar chart seems to be working on some blogs but not others. I’m going to figure out why it’s not working and probably add something to the settings page as an alternative so that the year can be changed/reset even if the graph isn’t working properly.

    EDIT… Changing the zoom on Chrome from 100% to 125% looks like the reason the year bar chart didn’t work.

    • This reply was modified 3 years, 9 months ago by shortdark.
    Plugin Author shortdark

    (@shortdark)

    Version 3.1.10…

    * Line graphs fixed.
    * Added the “Date Range” page, which currently gives an alternative way to select years.

    Plugin Author shortdark

    (@shortdark)

    Version 3.1.11…

    Should have fixed the non-integer bug.

    Version 3.1.12…

    I mistakenly added an experimental feature in the previous release (3.1.11), so I have kept this feature but added an explanation. The Date Range “start date/end date” feature may work for the bar charts but it has not been properly tested for anything else.

    Plugin Author shortdark

    (@shortdark)

    Version 3.1.14…

    Changed the wording on “Date Range” and made it an opt-in feature. This part is experimental and only works for the bar charts on the main page (not the pie charts or line graphs). It will probably get rewritten eventually but it is there at the moment for testing purposes.

    Plugin Author shortdark

    (@shortdark)

    Current bugs…

    * Many bugs on “date range” but one is that if you make the end date before the start date you end up with zeros instead of the bar charts.
    * Date range… make the pie charts and lists work within the date range.
    * Custom taxonomy page doesn’t refresh when you change the year, you have to reload the page for it to refresh the checklist.
    * Custom taxonomy… first color is pink (should be red).

    Plugin Author shortdark

    (@shortdark)

    Version 3.1.16…

    * Fixed Custom Taxonomy page so that changing year no longer breaks the checkbox list.
    * Fixed the color issue with the Custom Taxonomy pages.
    * Fixed export bug with the Custom Taxonomy.

    TODO…

    * “Date range”!

    Plugin Author shortdark

    (@shortdark)

    Bug on “Days Between Posts” where a user is selected and it only shows the all-time stats will be fixed in the next update.

    I’ll sort the date range out and add this bug-fix together with the date range fixes altogether in one update so that I’m not updating the plugin too frequently.

    Plugin Author shortdark

    (@shortdark)

    Version 3.1.17 seems fairly stable. I think I’ve fixed all the bugs that I was aware of.

    On the category/tag/custom pages if no items are selected and you click the button to view the graph it displays an empty graph. There should probably be some client-side validation there to prevent an empty graph being presented.

    If you have found any bugs please post them here, or make a new topic in the forum.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Bugs’ is closed to new replies.