Support » Plugin: WP Twitter Timeline » BREAKS STUFF

Viewing 15 replies - 1 through 15 (of 17 total)
  • Actually throws PHP errors in addition to notices, so yeah. It’s bad.

    twitter-timeline.php on line 233

    Warning: Invalid argument supplied for foreach() in /Users/hal/Documents/ArtFiles/web/Locality/BellyDance/dev2/wp-content/plugins/wp-twitter-timeline/wp-twitter-timeline.php on line 236

    Notice: Undefined variable: var_sOwnCSS in /Users/hal/Documents/ArtFiles/web/Locality/BellyDance/dev2/wp-content/plugins/wp-twitter-timeline/wp-twitter-timeline.php on line 243

    Same here, new plugin doesn’t work and is throwing PHP error:

    arning: Invalid argument supplied for foreach() in /home/stluhcom/public_html/wp-content/plugins/wp-twitter-timeline/wp-twitter-timeline.php on line 236


    Solved. Once I was able to fully set up this plugin/widget the error message went away.

    You have to create a Twitter widget and follow the instructions for adding your Twitter widget ID and such, but once it’s running it seems to be fine…at least in our case. More here:

    Twitter Timeline Widget

    I’m at a Lutheran church too Rich … I love your site.

    I think I followed the instructions … it looks right in the preview on Twitter, and it shows up on my site (, but the error warning about line 236 also displays at the top of my page 🙁

    Hi MN! A Lutheran church…in Minnesota?! I’m shocked! 😉 My wife’s relatives are still there for the most part…great place. And what a nice website!

    I looked around a bit but I didn’t see the Twitter feed on any of your web pages…might have missed it though. That error showed up right until I activated the plug-in and added the widget.

    I see you have a WP Titan theme too. With ours, anytime I make a change I have to then update a page for it to take effect. It doesn’t matter what page…I just open an existing page and hit the “Update” button and ta-dah! I don’t know if that’s a Titan thing or what, but…

    It was a bit of a pain to get it all working but if you’d like me to take a look, just send a message with the details through our website. (I hesitate to post my email here for all of the reasons you can imagine.) Have the office forward your note to Rich Adams and I’ll be happy to see if I can sort it out for you…

    Otherwise, the best I can suggest is to follow the directions here…

    Twitter Timeline Widget

    Hope that helps!

    D’oh…I see your Twitter feed now under “Updates”…just didn’t recognize it. At least that’s working. Here’s what our settings look like for the Twitter Timeline on our Home Page if that helps:

    Hmm … thanks for trying Rich … even if I change all my settings to the same as yours and tried your ‘update’ tip (although I’ve never had to do that before) it does the same thing 🙁

    I tried posting at … will see if I can get some help there … or it either comes right overnight …

    I think I’ve managed to bypass the plugin by using the copy-and-paste html code from the configurations page inside Twitter into a text widget.

    I got the idea from

    The error message still showed up when I took the Twitter widget off my sidebary, so I also had to deactivate and delete the plugin.

    So far so good …

    Nice work mn! No idea why this is an issue but glad to hear things are good again though.

    And thanks for posting back. So often folks post on the forum but never return so you never know if or how they resolved things.


    I have disabled the twitter in jetpack/ i have deleted the plug in for the twitter sidebar app..
    I still get/ wp-content/plugins/wp-twitter-timeline/wp-twitter-timeline.php on line 236
    My problem is I already had the usable code from twitter but investigating the plug in as well..
    I installed it and now i get that error…
    can i go into my php file and just delete line 236 and accompanying arguments??
    or is there an easier way?
    Do I have to reload wp 3.1?
    I am not having much success… and just want to get rid of the problem…
    It’s simple enough getting a twitter time line up.. in a text sidebar..
    so why did I go to that bloody time line plugin???
    my bad..
    is there a fix…

    Okay so I went into ftp and tried popping off the twitter files in the jetpack folder .. still messing up so..
    I did a Microsoft solve..
    I just wiped out the whole jetpack folder and presto no longer has that fussy grey bar with the error reading on top
    I can just go to my twitter accts and set up the timelines from there..
    which i was doing…
    I would suggest that no one downloads the twitter timeline widget until someone figures out what that error is..
    I run about 12 wordpress sites..
    Is jetpack really that useful or necessary??
    I just automatically place it on my site..
    it’s got easy read stats / the share buttons…
    but they’re all easily replaced..
    Is jetpack offering me anything that I can’t get with a better plugin?
    by the way
    i could have just uninstalled jetpack..
    but since i was already on the ftp site i just did it that way..
    For the life of me i could not locate the file in question.. it was not standing alone in the plugins folder… so i could not locate the php file
    it would be nice to rummage around inside to see what line 236 is actually doing to create such misery..
    has anyone talked to the plugin techs??

    I meant to post back here earlier. I’ve found, and this sounds completely counter intuitive, that turning off the WP Twitter Timeline plugin got rid of the error…and it still works!

    Once I installed the Twitter Timeline plugin and added the code to a widget I ended up turning off the plugin to get rid of the “…line 236” error displayed on our web page thinking that I’d work on a fix (or that the dev would). I then found that the widgets, located on our home page and a couple of others, continued to work fine. ??? Here are two pages on which Twitter Timeline has been working perfectly fine (with the plugin deactivated):

    So you might try deactivating the plugin, make a couple of additions to your Twitter account and see if things continue to work.

    Okay so thanks..
    I just realized that my error does not show on the home page.. but it shows on posts/pages/categories..
    this is getting really frustrating..
    is there an answer and how do i get rid of this thing from hell??
    what have i done… and what is it doing?
    I have removed the jetpack/removed the plug in
    why is the code still there??
    and where is the php file ??
    because it’s obviously still there…
    maybe a reload of my wp theme? or is it my wordpress needs updating
    I just want it gone..

    Hi Gav. We still use other JetPack features, so that’s not an option for us, but it wasn’t necessary to delete JetPack to fix the error message.

    Do you still have the WP Twitter Timeline plugin installed? As mentioned above we still have it (and JetPack) installed, but I deactivated WP Twitter Timeline, the error went away and things are good now…for whatever reason.

    The error would be thrown if there is a call for the PHP file on any page on your website. If so you’d have to remove it (possibly a widget call?).

    FWIW you should be able to find the actual PHP file by accessing your files (FTP in, etc.):

    WP Content > Plugins > wp-twitter-timeline > wp-twitter-timeline.php

    However I looked at that file originally and this is line 236:

    “foreach($array_widgetOptions as $key => $value) {” (w/o quotes)

    It and the following four lines are CSS commands. However I tried removing them completely once and the same error persisted. No idea why.

    A previous poster, mnplatypus, and I are using a WP Titans template, are you as well? Might have something to do with that…or nothing to do with that, hard to say.

    In any case, hope that helps, best of luck and let us know how things go!

    Never mind…
    I was using wpcache and found that i had to purge cache separately for each page
    And now it seems to be working okay..
    I will reload with jetpack
    I have a workaround for the twitter timeline in the sidebar.
    Terrance Gav
    The twitter.php file was gone… but my cache was holding onto the error message and i had to refresh each menu item individually..
    It was a strange error and thanks everyone for your kind help…

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘BREAKS STUFF’ is closed to new replies.