WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Secure WordPress Breaks Site!

[Resolved] Secure WordPress Breaks Site!

  • There needs to be a third option to augment broken/works called “Broke my site!”. Amateur hour.

    Warning: require(inc/swWSD.php) [function.require]: failed to open stream: No such file or directory in /home/content/88/7797788/html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 112

    Fatal error: require() [function.require]: Failed opening required ‘inc/swWSD.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/content/88/7797788/html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 112

Viewing 15 replies - 1 through 15 (of 22 total)
  • Tevya
    Participant

    @thefiddler

    Yep, upgrading killed my site too! DO NOT UPDATE!

    Tevya
    Participant

    @thefiddler

    I got the exact same error message about line 112. Removed the whole directory tree and will downgrade to 2.01.

    DO NOT UPGRADE!

    alan

    windracer
    Member

    @windracer

    Took me a while to figure out it was this plugin that killed my site. Thank goodness downgrading worked. Ouch.

    Same happened to me, I updated to new version of Secure WordPress plugin and it broke my site, not only would the admin panel no longer load the entire site would no longer load.

    Was able to fix by ssh’ing to my site and going to wp-content/plugin folder and manually deleting via rm -r secure-wordpress directory.

    then the site was back up with no problems.

    Hopefully the creator will update their plugin or post a reason why it’s breaking sites all of the sudden.

    Same thing happened to me..

    Luckily did a Google search and found this thread

    Deleted SecureWP plug-in directory over FTP and site is working again

    zicocarioca
    Member

    @zicocarioca

    Another victim here.

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/86/7318986/html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required ‘inc/json.php’ (include_path=’.:/usr/local/php5/lib/php:/home/content/86/7318986/html/wp-content/plugins/instapress/instagram-php-api/:/home/content/86/7318986/html/wp-content/plugins/instapress/classes/:/home/content/86/7318986/html/wp-content/plugins/instapress/PowerHour_Geocoder/’) in /home/content/86/7318986/html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    DO NOT UPDATE.
    If you did, delete the plug-in directory via FTP.
    Then cross your fingers, like you do every time you upgrade anything.
    Science, pff.

    soullotus
    Member

    @soullotus

    I updated 3 plug-ins..can’t remember what they were, and I got the same thing. I am not all that savvy. Since I can’t get onto my website, how do I fix this?
    I don’t know what FTP is.

    Gal Baras
    Participant

    @galbaras

    Just updated to 2.0.2 and got a missing JSON file message. Went back to 2.0.0 and it works.

    soullotus
    Member

    @soullotus

    If anyone else here is clueless like I am, I just called my hosting company, and they helped me fix this. When all else fails…good luck everyone.

    paulzag
    Participant

    @paulzag

    If you don’t know what FTP is you probably should NOT be automatically updating plugins.

    Your site will be fine. I think the developer accidentally left the sub-directories out of the package.

    Go vote BROKEN on the plugin directory so WordPress will hopefully remove the update here http://wordpress.org/extend/plugins/secure-wordpress/download/

    As others have said just delete the plugin directory. If you don’t know how to use SSH or FTP then do this:

    Log into the control panel of your site (normally cpanel or cp) use the file manager to navigate to wp-content/plugins/

    delete the secure-wordpress directory.

    install v2.0.1 from http://downloads.wordpress.org/plugin/secure-wordpress.2.0.1.zip

    Me too! I get a fatal error on line 112.

    microberto
    Participant

    @microberto

    LOL. Way to test. Breaks for me on WP 3.1.x

    zepolo
    Participant

    @zepolo

    Yep, upgrading killed my site too

    Remove this plugin !

    archproject
    Member

    @archproject

    Same here …. damn … got panic for a while and just deleted it via FTP and site works again. What the heck happened

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Secure WordPress Breaks Site!’ is closed to new replies.