Support » Theme: Dara » Blog page won’t go full width

  • I use the Dara theme on a Siteground hosted site. I’ve set all the pages to “full width, no sidebar” under Page Attributes, except for the blog page.

    The blog page does not have this option under Page Attributes, so it’s not wide screen.

    How can I make the blog page ‘full width,’ like all the other pages?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    @remotebliss The blog isn’t a static page – the page you assign your posts to is just a “dummy” page, and doesn’t follow the template selected. I know this isn’t intuitive, but it’s the same across all of WordPress.

    If you don’t add widgets to your sidebar, the blog should be full-width by default, however.

    Let me know how it goes.

    Hi Kathryn,

    Thanks for your message. I created a new blog page and assigned posts to it (deleted the ‘dummy page’), but my new blog page also doesn’t have the option to go full-width under page attributes. I haven’t assigned any widgets to it, either. Any suggestions for what to try next? Thanks

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    but my new blog page also doesn’t have the option to go full-width under page attributes.

    The blog doesn’t have a specific full-width option to select – sorry I didn’t make that clear enough.

    If you need further help I’d need to see your site directly.

    Hi Kathryn, you can see my blog here: https://remotebliss.com/

    You’ll notice that all the pages are full width except for the blog page. Thanks for your help!

    Hey, were you able to check out the blog page? Any suggestions? Thanks! 🙂

    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    Hi @remotebliss, the other pages, such as Get in Touch, have a max-width setting of 1180px, but the blog page has a max-width of 880px. Give this a try and see what you think.

    .blog .site {
    	max-width: 1180px;
    }
    .blog .post-thumbnail img {
    	width: 100%
    }

    Hi @sacredpath, that worked to make the blog page go full-width, thank you! Each blog post, however, is still narrow. Is there a way to make the posts consistent with the rest of the site?

    Hello All,

    I have the same problem, the blog page where I post latest news to has no option for full width template and is a narrow column of text instead.

    I am using Shoreditch theme. I saw the reply from @sacredpath about adding the code:

    .blog .site {
    max-width: 1180px;
    }
    .blog .post-thumbnail img {
    width: 100%
    }

    I added this code to Customise > Additional CSS, but the text remains in a column and not full width.

    Needless to say I am totally new to this so please excuse my lack of knowledge!

    https://britishcounties.org

    Thanks and regards,

    Andrew.

    • This reply was modified 1 year, 9 months ago by donaldsonac.
    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    Hi @remotebliss, I am seeing your blog posts full width now on your Blog page. Are you all set with that?

    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    Hi @donaldsonac, since you are using a different theme, and since CSS is theme specific, can you please start a new thread in the Shoreditch support forum? Many thanks in advance.

    Hello and thanks for your reply, I have been on it all day and found some other code that seemed to work, so I used that.

    Thanks again!

    AndrewD.

    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    You are welcome.

    @donaldsonac – I went to your page and see that you have figured out what code to use or change. Can you tell me please what you did to go full width?

    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    @remotebliss, you are using Shoreditch, not the Dara theme. Please post in that support forum at: https://wordpress.org/support/theme/shoreditch

    sacredpath

    (@sacredpath)

    Automattic Happiness Engineer

    @rjqueen, the same for you. Contact the theme author for the theme you are using. The site associated with your username is using the Extra theme, which looks to be an Elegant Themes creation.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Blog page won’t go full width’ is closed to new replies.