WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] blockUI requires JQuery (40 posts)

  1. sam ettenborough
    Member
    Posted 1 year ago #

    I am getting an alert on my website that says:
    blockUI requires jQuery v1.2.3 or later! You are using v1.10.2
    I have tried the following tips from this page:
    http://wordpress.org/support/topic/blockui-alert?replies=7
    This one points me to the master files, but the part of the files he says to delete are no longer there, so I am unsure why I am getting this error.

    Also I tried adding this code '<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js">
    </script>' to the header, but my problem is that I don't know which header.php file to add it to. I got this code from this website:
    http://ideasandpixels.com/blockui-requires-jquery-v1-3-or-later-quick-fix

    My site is konectidy.

    http://wordpress.org/plugins/woocommerce/

  2. sam ettenborough
    Member
    Posted 1 year ago #

    Also I just updated my version of wordpress to 3.6 and this error started happening.

  3. kcpearson
    Member
    Posted 1 year ago #

    I just updated one of our client sites to WP 3.6 as well and I started getting this same error message on the admin side of WordPress as well. "blockUI requires jQuery v1.2.3 or later! You are using v1.10.2".

    The site I'm getting this error on is not one running WooCommerce however. The site we have that's running WooCommerce is not having any issues at all.

  4. adrenalmix
    Member
    Posted 1 year ago #

    I had the same problem. I changed to folder " wp-includes/js " with older version 3.5.2. Everything improved.

  5. Roy Ho
    Member
    Posted 1 year ago #

    Not getting any error on my end...

  6. csgibson
    Member
    Posted 1 year ago #

    I just updated to version 3.6 and I get the same message everytime I try do do anything on my site. Does WordPress have a quick fix or do I have to fix it myself?

  7. sam ettenborough
    Member
    Posted 1 year ago #

    Changing the "wp-includes/js" folder to the older version did solve the problem. Hopefully woocommerce or wordpress will come out with a patch so I can keep my entire site up to date.

    Thanks for the help adrenalmix.

  8. Tenebral
    Member
    Posted 1 year ago #

    Same here. Waiting for the final fix :(

  9. bdm55
    Member
    Posted 1 year ago #

    Hi can anyone offer a little more detail on how to change to the older version of jQuery?

    Also ..it's not an e-commerce site. ..
    Thanks,
    Bill

  10. Johanhorak
    Member
    Posted 1 year ago #

    Would also like details on how to fix this.

  11. stgoldmann
    Member
    Posted 1 year ago #

    Oh yes, please! I have four WP-Sites to administer - it drives me crazy. Will there be a fix?

  12. Hamptonsmouthpiece
    Member
    Posted 1 year ago #

    I am getting this message (blockUI requires jQuery v1.2.3 or later! You are using v1.10.2) soon after I updated my wordpress....How do I stop this message from popping up everytime I go to a new screen? When will the fix be generated?

  13. Roy Ho
    Member
    Posted 1 year ago #

    Hmmmm I am still wondering why I am not seeing this message...

  14. steve_dawson
    Member
    Posted 1 year ago #

    I got the same problem when I updated to WordPress 3.6.

    I fixed it by installing the JQueryUpdater plugin

    Hope that helps somebody

  15. Johanhorak
    Member
    Posted 1 year ago #

    Thanks steve_dawson

  16. Tenebral
    Member
    Posted 1 year ago #

    FYI, my blockUI error was fixed by updating my theme, here is the explanation from the theme author:

    "Ohh, you’re right, it’s about blockUI from our login box feature."

    Theme: Gameleon (themeforest)

  17. helgatheviking
    Member
    Posted 1 year ago #

    I wanted to say it was resolved by updating my theme as well, but I am using the same themes on 2 sites and still get the error on 1 of them.

  18. kcpearson
    Member
    Posted 1 year ago #

    JQuery Updater plugin did not resolve our problem, but only because our issue was a plugin that we are using that was using an outdated version of blockUI. I had to disable each plugin until the Chrome pop-up window with the "blockUI requires jQuery v1.2.3 or later! You are using v1.10.2" error disappeared. Specifically it was a Calendar plugin that we were using that was causing the problem (All In One Event Calendar by TImely).

    To fix it I simply installed Timely updater, which notified us that we were using a plugin version that was not being supported any longer and that we needed to update to the newer build. That fixed the issue and error message went away.

  19. csgibson
    Member
    Posted 1 year ago #

    My problem was a Login Plugin. When I installed an updated plugin everything returned to normal.

  20. hugofreak
    Member
    Posted 1 year ago #

    Hi there Guys, I had a custom theme (developed by my self) and I updated the code and noted that I still had the same issue with this error, what I did to fix it was disable all my plugins and reanable them one by one. I note that one of my plugins when I eneble it (In my case was CalPress Calendar plugin) it give me the same error again. I left that plugin disabeled and now my WordPress instalation is working like a charm.

    In other words review the plugins install on your wordpress site.

    I hope it helps!

  21. Mark Peal
    Member
    Posted 1 year ago #

    Thanks, hugofreak. I disabled CalPress Calendar, and now everything is OK. If you visit the CalPress Pro website, calpresspro.com, their site is throwing the same error (at least as of 2 Aug 2013, 3:45 pm EDT).

  22. KennyKfromtheBay
    Member
    Posted 1 year ago #

    The offending plugin on my site was "Anthologize" Version 0.7 By One Week, One Tool. Thanks hugofreak.

  23. cardened
    Member
    Posted 1 year ago #

    Hi

    I just installed a new WP with Version 3.6 and it was working fine. After I installed a plugin, I got that same error.

    I tried the "jQuery Updater" unsuccessfully.

    I came across this other post which I think is the solution:
    http://wordpress.org/support/topic/wordpress-36-and-jqueryblockui-version-problem-solution?replies=10

    Basically it says it is a problem of the jQuery that is being called on the plugin. You will have to try, as stated above, deactivating some plugins and see if you find which one is the one that is giving a problem, and tell them to update their plugin so that it works without that error message.

  24. helgatheviking
    Member
    Posted 1 year ago #

    Looks like my client had 2 versions of woocommerce running at once. Definitely check all the plugins one by one to find the culprit... or switch to TwentyThirteen if you think it is the theme.

  25. cardened
    Member
    Posted 1 year ago #

    Hi guys... I just followed the instructions on this post:
    http://wordpress.org/support/topic/wordpress-36-and-jqueryblockui-version-problem-solution?replies=10

    I found the jQuery.Block.UI file on my plugin that was causing the problem and changed it with the updated version that he mentioned (http://malsup.github.io/jquery.blockUI.js), and it solved the problem.

    I event sent the Plugin Author the update so that he could fix it!!!

  26. Tech4Eleven
    Member
    Posted 1 year ago #

    my issue was with a plugin called All-in-One Calendar by Then.ly (i know. not 'time.ly')

  27. vikram2030
    Member
    Posted 1 year ago #

    steve_dawson thank you. It works perfectly

    Just Search plugin jQuery Updater

    and install it.

    It works 100% percent.

  28. orlandomario
    Member
    Posted 1 year ago #

    Fixed my problem with Jquery Updater plugin.

  29. MadMare
    Member
    Posted 1 year ago #

    Thanks to everyone who posted about the Jquery Updater Plugin. I installed that and everything was fixed.

    WHEW!

  30. MadMare
    Member
    Posted 1 year ago #

    Whoa. Yah, that fixed my problem on the front end, but now the back end is doing it. Weird.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic