Support » Fixing WordPress » Block/Visual Editor Doesn’t Work

  • Resolved Jim

    (@jwmc)


    The Block Editor is not working for me. When I try to create a new page, the ‘+’ button is greyed out. Adding paragraphs does not add new blocks, ‘i’ shows only one block.

    The Block Navigation button opens to show ‘Classic’. If I click that, a ‘More Options’ menu appears that contains ‘Convert to Blocks’. Doing that then shows HTML, e.g.:

    <!-- wp:paragraph -->
    <p>Can't create blocks<br>
    asdfads<br>
    aasdfds</p>
    <!-- /wp:paragraph -->

    But the More Options menu has a choice ‘View as HTML’.

    I have flushed all caches and tried development mode on CloudFlare. My user settings have a nickname and ‘Disable visual editor’ is unchecked, but I toggled those settings to make sure. I resaved permalink settings.

    I disabled all plugins with the Health and Troubleshooting plugin. Nothing has worked.

    In the javascript console for the edit page, the following appear:

    Request to access cookie or storage on “https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&ver=5.2” was blocked because we are blocking all third-party storage access requests and content blocking is enabled. post-new.php
    JQMIGRATE: Migrate is installed, version 1.4.1 load-scripts.php:8:542
    onmozfullscreenchange is deprecated. components.min.js:12:80762
    onmozfullscreenerror is deprecated. components.min.js:12:80762
    Request to access cookie or storage on “https://cdnsure.com/assets/style” was blocked because we are blocking all third-party storage access requests and content blocking is enabled. post-new.php

    I don’t really understand this. I am dead in the water here – please help!
    WordPress is 5.2.

Viewing 3 replies - 16 through 18 (of 18 total)
  • So, to summarize, the problem occurs:

    1. in Firefox but not Safari.
    2. with all plugins deactivated
    3. with the default theme
    4. after flushing all caches, and Cloudflare in development mode
    5. with user having a nickname and ‘Disable visual editor’ not checked
    6. after resaving permalink settings
    7. after manually reinstalling WordPress
    8. with REST API available

    On the page edit page, with debugging active, the following warnings (W) and errors (E) appear in javascript console (I cleared the content blocking errors):

    1. JQMIGRATE: Migrate is installed with logging active, version 1.4.1 jquery-migrate.js:23:2
    2. (W) onmozfullscreenchange is deprecated. components.js:6575:33
    3. (W) onmozfullscreenerror is deprecated. components.js:6575:33
    4. (W) JQMIGRATE: jQuery.fn.load() is deprecated jquery-migrate.js:45:4
      console.trace() jquery-migrate.js:47:5
      jQuery 2
      <anonymous> https://forestpathology.org/wp-content/themes/generatepress/js/admin/block-editor.js?ver=2.2.2:87
    5. (W) JQMIGRATE: ‘ready’ event is deprecated jquery-migrate.js:45:4
      console.trace() jquery-migrate.js:47:5
      jQuery 9
      <anonymous> https://forestpathology.org/wp-content/plugins/profile-builder/features/content-restriction/assets/js/content-restriction.js?ver=2.9.9:29
      jQuery 4
    6. (E) Warning: Unsafe lifecycle methods were found within a strict-mode tree:
      in StrictMode (created by Editor)
      in Editor (created by ComponentWithSelect)
      in ComponentWithSelect (created by Context.Consumer)
      in WithSelect(Editor)

      componentWillUpdate: Please update the following components to use componentDidUpdate instead: FillComponent

      Learn more about this warning here:
      https://fb.me/react-strict-mode-warnings react-dom.js:500:7

    7. (E) Warning: Can’t call setState on a component that is not yet mounted. This is a no-op, but it might indicate a bug in your application. Instead, assign to this.state directly or define a state = {}; class property with the desired state in the t component. react.js:276:7​

    I found the problem. It was a Firefox extension called User-Agent Switcher. Disabling that fixed the block editor. Thanks for your help @t-p.

    Moderator t-p

    (@t-p)

    Glad its sorted 🙂

Viewing 3 replies - 16 through 18 (of 18 total)
  • You must be logged in to reply to this topic.