Support » Plugin: Page Builder Gutenberg Blocks – Kioken Blocks » Block Validation failed

  • Resolved Dewey Bushaw

    (@styledev)


    I am constantly getting the “This block contains unexpected or invalid content. [Resolve] [Convert to HTML]” for core blocks because “Block Validation failed” in the console. I am not sure if this is because you are extending the core items with the added features but this is very disruptive for our clients. Is this a known issue and is a fix coming soon?

    index.js:2 Block validation: Block validation failed for core/image (Object).

    Content generated by save function:

    <figure class=”wp-block-image alignwide size-full has-animator”></figure>

    Content retrieved from post body:

    <figure class=”wp-block-image alignwide size-full has-animator” data-anim-from=”vertical” data-anim-duration=”1″ data-anim-rewind=”true” data-anim-distance=”100″ data-anim-scale-x=”1″ data-anim-scale-y=”1″ data-anim-easing=”easeInOut” data-anim-effect=”Cubic”></figure>

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Onur Oztaskiran

    (@sj_o)

    Hi @styledev

    This is not a known bug but a first time. I wonder if another plugin inflicting the cause of a validation issue since I see there are a couple plugins installed on the site.

    Also, I figure you’re using the development version of the Gutenberg plugin. Kioken Blocks is tested working well for Gutenberg plugin up to 6.8 and not tested for 6.9 and 7.0 (which was released yesterday) yet.

    I would suggest using the block editor in the WordPress core, not the development version of the block editor.

    Thanks!
    Onur

    Plugin Author Onur Oztaskiran

    (@sj_o)

    I revisited this issue but couldn’t reproduce but I still have a feeling it may be about the Gutenberg plugin.

    Could you try turning off the Gutenberg plugin and use the block editor of the WordPress itself and see if it resolves the issue?

    Thanks,
    Onur

    Plugin Author Onur Oztaskiran

    (@sj_o)

    @styledev I am going to resolve this topic since I’ll assume it’s resolved.

    Cheers!
    Onur

    @sj_o I disabled the Gutenberg plugin and I am still getting the conflict blocks, further when I go to resolve there is no difference in the Diffs though it does highlight code the code is the same as the original. This is happening specifically with blocks that specify font changes. When I click resolve though, the font changes are not carried over to the resolved block. Maybe this has to do with the blocks being originally created with the Gutenberg plugin active.

    I am assuming though that what ever is causing this issue with the Gutenberg plugin you will need to resolve it by the time WordPress core upgrades the core version to the latest plugin version of Gutenberg…

    Plugin Author Onur Oztaskiran

    (@sj_o)

    Hi @styledev

    Thank you! I’ll check again with the details you provided and thank you for reporting!

    Will update if I find anything.

    Thanks!
    Onur

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.