WordPress.org

Support

Support » Plugins and Hacks » Membership 2 » [Resolved] Blank settings pages after update

[Resolved] Blank settings pages after update

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey there.

    Can you please try removing the old version totally (even if upgraded), then upload a fresh version.

    If this still persists then can you please check what error is out put with DEBUG:

    http://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG

    Please let us know what’s output.

    Cheers.

    Hey there just checing in to see if you saw our reply

    Hey sorry, forgot to update the situation.

    I deleted the old version of membership, installed the new one, didn’t work, still blank page.

    Here’s what I got when running in debug mode:

    Fatal error: Call to undefined method stdClass::set_help_sidebar() in /home/igemust/public_html/wp-content/plugins/membership/membershipincludes/classes/class.help.php on line 73

    Thanks for helping!

    ellbristow

    @ellbristow

    WPMU DEV Support Staff

    Hi @hyht2013,

    I’ll pass this on to our developers to take a look at.

    While we wait for their comments, if you are happy to edit the php file in question, you could change line 73 from:

    $this->screen->set_help_sidebar( $help );
    To
    if ($this->screen != false) $this->screen->set_help_sidebar( $help );

    It’s not a permanent fix but it will at least clear this error and allow us to see if there are any other issues that need addressing.

    Thanks

    Hi ellbristow,

    I did that, the error persisted. I ran wp in debug mode again, the message was still the same:

    Fatal error: Call to undefined method stdClass::set_help_sidebar() in /home/igemust/public_html/wp-content/plugins/membership/membershipincludes/classes/class.help.php on line 73

    Thanks.

    ellbristow

    @ellbristow

    WPMU DEV Support Staff

    Hmm… OK. I guess we’ll have to wait for the devs to take a closer look then. Bear with us and we’ll get back to you.

    ellbristow

    @ellbristow

    WPMU DEV Support Staff

    Our devs have just come back to me to tell me that the problem here is most likely your WordPress version.

    I notice you have said your version is 3.1.4. The method that the plugin can’t find was introduced in WordPress 3.3, so an update to your WordPress installation should fix this problem.

    Let me know if that fixes things for you.

    Thanks for the reply.

    Unfortunately I am limited to WordPress 3.1.4 because of the php requirement of the server. I am using a server offered by my university, and they are not going to upgrade that.

    Guess I need other options, but thanks for the help! Really appreciate it.

    ellbristow

    @ellbristow

    WPMU DEV Support Staff

    Wow… sounds like your university need some education in web hosting! 🙂

    Sorry we can’t fix this one… catch you on the next one 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Blank settings pages after update’ is closed to new replies.
Skip to toolbar