Support » Plugin: TablePress » Audio not working; File not found

  • Resolved mireillesan

    (@mireillesan)


    For some odd reason the audio doesn’t work in tablepress anymore.

    I use the standard audio player and also have your plugin (TablePress Extension: Audio Player in table cells) installed. I also tried to add the shortcode in a page directly, and then the audio plays perfectly without problems.

    Any idea on how to solve this?

    http://wordpress.org/plugins/tablepress/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your question, and sorry for the trouble.

    My assumption here is that the new [audio] Shortcode that is not availabe in WordPress directly is interfering here.

    Could you please post a link to the page with the table where this is not working, so that I can take a look at it? Thanks!

    Regards,
    Tobias

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for the link!

    I’m not exactly sure, but I think that there’s a / missing in the URL of the mp3. The URL seems to start with http:/ and not http://.
    Could you please check that?

    Regards,
    Tobias

    That’s odd, I checked and there are two slashes.
    [audio:http://www.newjlpt.com/audio/JLPTN3/JLPTN3-track112.mp3%5D

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    that’s weird then…
    The audio player then makes a request to get the file from
    http://www.newjlpt.com/audio/JLPTN3/:http://www.newjlpt.com/audio/JLPTN3/JLPTN3-track112.mp3 which is wrong, of course…

    I therefore suggest that you switch to the native WordPress Audio Shortcode, without the extra plugin. So, please deactivate the Audioplayer plugin and the TablePress Extension and then change the Shortcode to

    [audio src="http://www.newjlpt.com/audio/JLPTN3/JLPTN3-track112.mp3"]

    Regards,
    Tobias

    Just did that, and now it works. 🙂
    So the problem lies with the Audioplayer plugin?

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    good to hear that! 🙂

    It’s likely that the problem is with the Audioplayer plugin, or maybe with the combination of the plugin and the new function in WordPress 3.6. It’s definitely not caused by TablePress or the Extension.

    Regards,
    Tobias

    I almost forgot, when I use the shortcode inside a page… then it does work fine.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    yes, the WordPress Shortcode has some different behavior then (as it runs after the Audioplayer plugin). That’s why it does not happen there.

    Still, using the WordPress core function for this is much better, as you need one less plugin, which in this case is better for performance 🙂

    Regards,
    Tobias

    Oh well nevermind. I’ll simply use a different player. 🙂
    Either way, thank you so much for your help!

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    yes, just the one that WordPress offers 🙂 That’s the easiest, and you won’t need to look for another player!

    Best wishes,
    Tobias

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Audio not working; File not found’ is closed to new replies.