Support » Plugin: Very Simple Contact Form » Attribute “maxlength”

  • Resolved Malae

    (@malae)


    Hi Guido,

    Can you check this:

    Line 431: Attribute “maxlength” is only allowed when the input type is “email”, “password”, “search”, “tel”, “text”, or “url”.
    
    label> <input type="hidden" name="vscf_captcha_hidden" id="vscf_captcha_hidden" maxlength="75" value="607" /> <i~
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Guido

    (@guido07111975)

    Hi,

    Did not know about this.. and will remove the maxlength attribute again.

    Just curious, what tool/website are you using to validate?

    Guido

    Hi Guido,

    I run several sites on WAMP and I use the Validator plugin for a quick check on pages, although it will sometimes show syntax errors that I cannot track down. The ‘maxlength’ issue showed up with this plugin. I leave debug.php running and also like to get rid of PHP notices to prevent filling the log file.

    For active sites I run validator.w3.org/nu/ to check HTML, CSS and SVG. The ‘maxlength’ threw an amazingly long explanatory list of attributes:

    Error: Attribute maxlength not allowed on element input at this point.
    
    From line 780, column 4; to line 780, column 105
    
    label>↩			<input type="hidden" name="vscf_captcha_hidden" id="vscf_captcha_hidden" maxlength="75" value="312" />↩			<i
    
    Attributes for element input:
    Global attributes	
    accept	        when type is file
    alt	        when type is image
    autocomplete	when type is text, search, url, tel, email, password, date, month, week, time, datetime-local, number, range, or color
    autofocus	
    checked	        when type is checkbox or radio
    dirname	        when type is text or search
    disabled	
    form	
    formaction	when type is submit or image
    formenctype	when type is submit or image
    formmethod	when type is submit or image
    formnovalidate	when type is submit or image
    formtarget	when type is submit or image
    height	        when type is image
    list	        when type is text, search, url, tel, email, date, month, week, time, datetime-local, number, range, or color
    max	        when type is date, month, week, time, datetime-local, number, or range
    maxlength	when type is text, search, url, tel, email, or password
    min	        when type is date, month, week, time, datetime-local, number, or range
    multiple	when type is email or file
    name	
    pattern	        when type is text, search, url, tel, email, or password
    placeholder	when type is text, search, url, tel, email, password, or number
    readonly	when type is text, search, url, tel, email, password, date, month, week, time, datetime-local, or number
    required	when type is text, search, url, tel, email, password, date, month, week, time, datetime-local, number, checkbox, radio, or file
    size	        when type is text, search, url, tel, email, or password
    src	        when type is image
    step	        when type is date, month, week, time, datetime-local, number, or range
    type	
    value	        when type is not file or image
    width	        when type is image
    
    Error: Attribute maxlength is only allowed when the input type is email, password, search, tel, text, or url.
    
    Plugin Author Guido

    (@guido07111975)

    Thanks for your response.. this is very helpful. I only have de-bugging activated on my production / local website, so did not get this w3 warning.

    I will remove the maxlength attribute again in next update.

    Guido

    Plugin Author Guido

    (@guido07111975)

    Hi,

    Have updated plugin so I’m marking this thread resolved.

    Guido

    Thanks Guido!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Attribute “maxlength”’ is closed to new replies.