Jetpack by WordPress.com
[resolved] array key warning (10 posts)

  1. sherryfredley
    Posted 2 years ago #

    array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /home/sherry/public_html/wp-content/plugins/jetpack/modules/photon.php on line 183

    I have this warning site wide and am having a really difficult time uploading images.



    PS- I am not a coder- I am a copy/paster button cclicker ;)


  2. mingab
    Posted 2 years ago #

    I have this same problem. Since I can't find a solution I can understand, I've had to deactivate Jetpack and I really miss it. What can be done?

    (I'm using Twenty Twelve (ver. 1.1) theme and WordPress version 3.5)

  3. lauragiusti
    Posted 2 years ago #

    Same problem here!! I deactivate it, reactivate it and seemed to be solved, but it wasn't...
    Using WP v.3.5 and Inuit Types theme.

  4. sherryfredley
    Posted 2 years ago #

    I deactivated Photon and that did the trick- I had to go back and re-upload a few pics and make some changes- it re-sized images- but once deactivated it seemed to solve it.

    Kind of a shame, I liked having photon and it loaded quicker.

    Hope this helps, let me know!

  5. lauragiusti
    Posted 2 years ago #

    Thank you sherry. How did you deactivated photon? I don't know how to do it

  6. javotroya
    Posted 2 years ago #

    You have to deactivate photon, that solves the problem for now. In order to do it yo have to go to jetpack panel and go to the photon widget click on More info and then the Deactivate button will appear.


  7. lauragiusti
    Posted 2 years ago #

    Thank you! :)

  8. Vix
    Posted 2 years ago #

    thankyou so much

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    Thanks for the reports.

    We have fixed this issue, and it’ll be part of the next Jetpack release.

  10. grklinguist
    Posted 2 years ago #

    Thank you to all of you. I just started having this same problem yesterday. It was driving me insane. Finding your discussion has been a life saver! Deactivating photon took care of it

    Here's the page now, with the problem gone!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic