Support » Plugin: Comment Mail » Are there compatibility issues to PHP 7.x?

  • collapsing_os

    (@collapsing_os)


    Hi there,

    I recently checked my page with the plugin “PHP Compatibility”. And unfortunately there are some compatibility issues regarding “Comment Mail” and PHP 7.2. Is this something to be concerned?

    FILE: /path/to/wp-content/plugins/comment-mail/src/vendor/websharks/wp-php-rv/src/includes/functions/notices.php
    ------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------------------------------------
     198 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    ------------------------------------------------------------------------------------------------------------------------------------
    
    FILE: /path/to/wp-content/plugins/comment-mail/src/includes/classes/UtilsFs.php
    -----------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------
     106 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    -----------------------------------------------------------------------------------------------------------
    
    FILE: /path/to/wp-content/plugins/comment-mail/src/includes/classes/UtilsEnc.php
    -------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 28 ERRORS AFFECTING 9 LINES
    -------------------------------------------------------------------------------------------------------------------------------------------------------
     124 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     124 | ERROR | Function mcrypt_list_algorithms() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     125 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     125 | ERROR | Function mcrypt_list_modes() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     130 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     130 | ERROR | Function mcrypt_get_key_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     130 | ERROR | The constant "MCRYPT_RIJNDAEL_256" is deprecated since PHP 7.1 and removed since PHP 7.2
     130 | ERROR | The constant "MCRYPT_MODE_CBC" is deprecated since PHP 7.1 and removed since PHP 7.2
     131 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     131 | ERROR | Function mcrypt_get_iv_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     131 | ERROR | The constant "MCRYPT_RIJNDAEL_256" is deprecated since PHP 7.1 and removed since PHP 7.2
     131 | ERROR | The constant "MCRYPT_MODE_CBC" is deprecated since PHP 7.1 and removed since PHP 7.2
     133 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     133 | ERROR | Function mcrypt_encrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     133 | ERROR | The constant "MCRYPT_RIJNDAEL_256" is deprecated since PHP 7.1 and removed since PHP 7.2
     133 | ERROR | The constant "MCRYPT_MODE_CBC" is deprecated since PHP 7.1 and removed since PHP 7.2
     171 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     171 | ERROR | Function mcrypt_list_algorithms() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     172 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     172 | ERROR | Function mcrypt_list_modes() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     184 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     184 | ERROR | Function mcrypt_get_key_size() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     184 | ERROR | The constant "MCRYPT_RIJNDAEL_256" is deprecated since PHP 7.1 and removed since PHP 7.2
     184 | ERROR | The constant "MCRYPT_MODE_CBC" is deprecated since PHP 7.1 and removed since PHP 7.2
     186 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
     186 | ERROR | Function mcrypt_decrypt() is deprecated since PHP 7.1 and removed since PHP 7.2; Use OpenSSL instead
     186 | ERROR | The constant "MCRYPT_RIJNDAEL_256" is deprecated since PHP 7.1 and removed since PHP 7.2
     186 | ERROR | The constant "MCRYPT_MODE_CBC" is deprecated since PHP 7.1 and removed since PHP 7.2
    -------------------------------------------------------------------------------------------------------------------------------------------------------

    Thanks for clarification,
    Henning

    The page I need help with: [log in to see the link]

  • The topic ‘Are there compatibility issues to PHP 7.x?’ is closed to new replies.