Support » Plugin: Gust » API error: parsererror on new host

  • First I’ve got to say I’m really excited for the new version! So glad you’re doing this.

    But I’ve run into a problem. I recently moved one of the sites I’m using Gust on, to CloudWays.com, which uses DigitalOcean with a VMAN stack. After migrating everything appears to work fine, except for Gust, which is giving an “API error: parsererror” with what appears to be an entire post in the error, above the 2-pane editor, which is empty.

    Any ideas?

    https://wordpress.org/plugins/gust/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Arunas Liuiza

    (@ideag)

    Hi,

    parsererror generally means there is some additional output on the API call response. could you give me a screenshot of the error?

    Any progress on this? On another site (other hosting) it seems to work fine, but I do see an “API error” briefly on login, before the Gust interface loads. So seems like there’s maybe a few things that need ironed out.

    Plugin Author Arunas Liuiza

    (@ideag)

    Hi, sorry for late reply. I am having trouble of replicating this so far. Could you please provide details about your system – what PHP version are you using, what other plugins are you using?

    MySQL = 5.5.37
    PHP = 5.4.4-14+deb7u11
    Active plugins: gravityforms/gravityforms.php, akismet/akismet.php, all-in-one-seo-pack/all_in_one_seo_pack.php, auto-post-thumbnail/auto-post-thumbnail.php, backupbuddy/backupbuddy.php, better-wp-security/better-wp-security.php, bruteprotect/bruteprotect.php, disable-comments/disable-comments.php, feedburner-plugin/fdfeedburner.php, forget-about-shortcode-buttons/forget-about-shortcode-buttons.php, google-analyticator/google-analyticator.php, gravityformsmailchimp/mailchimp.php, gravityformspolls/polls.php, hotfix/hotfix.php, mailchimp-for-wp/mailchimp-for-wp.php, nrelate-flyout/nrelate-flyout.php, nrelate-most-popular/nrelate-popular.php, regenerate-thumbnails/regenerate-thumbnails.php, rvg-optimize-database/rvg-optimize-db.php, shadowbox-js/shadowbox-js.php, shadowbox-js/shadowbox-title-push.php, subscribe-to-comments-reloaded/subscribe-to-comments-reloaded.php, weasels-html-bios/wz_html_bio.php, wp-post-series/wp-post-series.php, wp-super-cache/wp-cache.php, wpmandrill/wpmandrill.php

    I can get you access if you’d like to poke around.

    Plugin Author Arunas Liuiza

    (@ideag)

    Access would be perfect for debugging. If you could write to arunas (at) liuiza (dot) lt

    Okay, you should have received credentials from WP.

    EDIT: I was seeing API errors on my personal blog as well, so I’d disabled it. I found another plugin was causing some problems, and disabled it. I just now went back and enabled Gust to see if that other plugin had been the problem, but it wasn’t. Still seeing errors there too, but not big long ones like on the 1st site. So I added you to my personal blog as well, you should receive a separate email with login details for that one.

    The 1st one is on CloudWays hosting which runs a VMANN stack. The 2nd one (personal blog) is on a fairly typical LAMP stack with suPHP. The unique thing about it, is rather than the typical cPanel, it’s running InterWorx. Not sure if either of these setups would affect any of this, but just so you know. Also You can go to BackupBuddy>Server Tools on both sites, to get details on PHP version, MySQL version, etc.

    Plugin Author Arunas Liuiza

    (@ideag)

    Ok, on the other site WP Super Cache is the culprit. It is adding a line <!-- WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed! --> to the output of everything and that makes Gust’s json unreadable. Make that message go away (by fixing WP Super Cache or getting rid of it completely) and things should run smoothly. If you use caching, make sure Gust is not being cached (by white-listing /gust/* and /api/*)

    On your personal site I see a 500 error on some API calls. Problem is, the errors are not detailed. I would need to see server log file to find actual error.

    Completely removed WP Super Cache, and it appears to be working great! Thank you. I’ll have to look into the other one. What log file would you need?

    Plugin Author Arunas Liuiza

    (@ideag)

    Glad to hear. I would need to see the Apache error.log file.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘API error: parsererror on new host’ is closed to new replies.