WordPress.org

Support

API endpoint

Viewing 15 replies - 1 through 15 (of 35 total)
  • Your xmlrpc.php file should be located at:

    http://www.shortforstephen.com/xmlrpc.php

    Did you not upload this file with your WordPress installation?

    Same issue, I was unaware that wordpress had an xmlrpc in the installation. Mine didn’t unzip with all the other stuff. Is there a way to get this file?

    mi327:
    I came across the same problem as you did. So what shall I do? I get my blog from blogsome.com which is powered by WordPress.

    I just upgraded and WP1.5 has it.

    Mine is there. I looked in the folder but I still get that error message.
    Anyone?

    I am also recieving an error on trying to add my blog to Flickr. “The endpoint you entered was not correct.” When I added www. to the beginning of my url, it was fine.

    The xmlrpc.php thing worked for me in setting up a “Perspective” from iUpload. Unfortunately, the perspective got a little distorted from that point on. If you’re interested in more, the relevant post to my iUpload blog is at:
    http://andwat.iuplog.com/default.asp?item=91672

    it should be located in your wordpress installation directory.

    If you’re sure its there and you’re still getting errors, be sure you are running the latest version of WordPress, as xmlrpc has undergone a great deal of change due to a security vunerability.

    i have a hosting plan where i set up some “add-on” domains in cpanel. the main site is http://www.moondreams.net. the add on is http://www.whatever.net. on whatever.net, i set up a subdomain called tony. the tony folder is under the main moondreams.net site, so i can either go to tony.whatever.net or http://moondreams.net/tony/ to get to that site. entering http://tony.whatever.net/xmlrpc.php didn’t work, probably due to some htaccess rewrites or something. so i tried http://www.moondreams.net/tony/xmlrpc.php and i worked fine.

    note: i don’t really own “whatever.net” – that’s just an example since i’m still working on the actual domain.

    -jim

    one more thing – i just tested it and it didn’t work the first time. following the advice on flickr that “web services are sometimes flaky,” i clicked the “try again” button and it posted. so don’t get discouraged the first, second, third … hundredth time. just try again.

    I had the same problem, and that’s because I have my WP installation in a different directory. Flickr tells you to use http://www.yoursite.com/xmlrpc.php and mine is actually in http://www.yoursite.com/wp/xmlrpc.php.

    I added the directory in, and it worked.

    I having the same problem. I have two installations of WordPress. The one I’m trying to get working is running 1.5. Why is this not working? I’m sure it’s the right folder and file. Why is this not working as it should!?!

    I have been having this problem for days now and can’t fix it – if xmlrpc.php is in my site root folder, it won’t work, but if it is in a subdirectory it will … I wonder if setting up a redirect to it will work, or if I’m going to have to change the code itself trying to ping to it?

    I’m also getting desperate with this problem. To some it works and to some it does not. I’d really appreciate if someone would give a reason to this. I’ve tried to put the xmlprc.php file to a subfolder, but that does not help at all. 🙁 Pretty mysterious shit.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘API endpoint’ is closed to new replies.