WordPress.org

Support

Support » Plugins and Hacks » WP eCommerce » [Resolved] Amazon S3 credentials suddenly not recognised.

[Resolved] Amazon S3 credentials suddenly not recognised.

  • WP e-Commerce: Version 3.8.12.1
    WP e-Commerce S3 Downloader: Version 1.2
    WordPress 3.5.2

    Downloads have been working fine until previously. However, the last successful download was Nov 6th so can’t be sure when it stopped working (It’s now Dec 4th).

    I noticed today when I tried to change the file associated with a product. Files are all on amazon s3. I get this error in the S3 settings:

    “The provided user name and password are incorrect”

    Amazon has a new access/secret key system coming in soon, so I tried updating to the new key pair, but still does not work. Still get the same error message.

    I also use Cyberduck to connect to my S3 buckets and this is still working fine with the same credentials.

    Any ideas?

    Cheers

    http://wordpress.org/plugins/wp-e-commerce/

Viewing 4 replies - 1 through 4 (of 4 total)
  • I think the plugin must have become corrupt. I got the getshopped people to resend the files, re-uploaded and it’s now working.

    Plugin Author Edward

    @edwardinstinct

    Sorry I wasn’t able to assist you here sooner…

    Happy you have the issue resolved!

    Regards
    Edward

    Hi, I’m having this same issue. I got a new copy of the S3 Downloader plugin from WPEC, and tried generating a new access key and secret key, but no luck. I still get the error “The provided user name and password are incorrect” on the plugin setup page.

    Do you have any ideas about what else could be causing the problem?

    I also get this warning on the plugin page:

    Warning: S3::listBuckets(): [7] Failed to connect to 72.21.195.174: Permission denied in /home/www/soundcarrier.net/wp-content/plugins/wpec-s3-downloader/Class-S3-base.php on line 91

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Amazon S3 credentials suddenly not recognised.’ is closed to new replies.
Skip to toolbar