WordPress.org

Support

Support » Themes and Templates » Am I doing this correctly?

Am I doing this correctly?

  • Don’t really know how to explain this but here goes.
    I have 4-5 templates in WP 1.5. Each has the “Template Name: Name” comment at the top to identify them to WP as templates.
    One of them for example is “about.php”. In the about.php file after the template name I have the usual WP tags and divs and content that I want displayed.
    I created a page named “About” in the admin and used this “about” template for it. Everything works fine but if I go to “manage pages” and edit the page the edit window shows nothing. There’s nothing to edit. The page is there – it displays on the blog just fine but the only way I can edit it is by going into “manage files” or do it locally.
    I’m not totally grasping the WP “page” idea – or am I? Is this the way “pages” are meant to be used?

    My WP

Viewing 5 replies - 1 through 5 (of 5 total)
  • There are step-by-step instructions on how to set up your Pages using template files (you are close but not totally right on) at http://codex.wordpress.org/Pages that will help you go through each step of the process.

    Ah… Lorelle beat me to the answer.

    But while I’m here, What font are you using for your title images?

    Thanks

    Thanks guys. I’ve read the codex and was hoping for a clearer explanation. I’ll read it again – SLOWER this time ;).

    Marc – the font is “Neat Freak Bold”. Don’t remember where I found it – maybe it was in the newsgroups.

    In the about.php file after the template name I have the usual WP tags and divs and content that I want displayed.

    That’s the problem! The content should have been added in the Write Page section when creating the Page, and then you can edit it, too. If your content is “hardcoded” in the template, obviously you cannot edit it in the Manage Pages section, since you didn’t put anything there in the Write section. Does it make sense?

    Ahhhh…..my eyes have been opened!
    Thanks moshu. I’m going to change a few things and see what happens.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Am I doing this correctly?’ is closed to new replies.
Skip to toolbar