Support » Plugin: Tracking Code Manager » After placement not positioned correctly

  • Hi… it seems like the option to place code after <body> isn’t placing the code correctly.

    Before </HEAD> works,
    Before </BODY> works,
    After <BODY> fails — in my experiments it always behaves like </BODY> and doesn’t place the code after <BODY>. If you look at page source with After <BODY> placement selected, the code is placed right before </BODY> and not after <BODY>.

    -Norm

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author IntellyWP

    (@intellywp)

    Hi @normsash,
    Thanks for choosing IntellyWP products.

    Unfortunately WordPress does not permit to put scripts right after the head tag
    Anyway everywhere you place should be fine, if you can send us a page we could even verify it for you!

    Please let us know

    Thank you

    Cheers

    IntellyWP

    Hey, thanks for the reply.

    The /HEAD placement option works find. That’s not the one misplaced. It is the “After <BODY> placement option that is wrong. Selecting that option in TCM places the code before </BODY> rather than after <BODY>.

    Plugin Author IntellyWP

    (@intellywp)

    Hey Norm

    I’ll forward this ticket to our dev team, they will remove “After <BODY>” option i guess.

    Unfortunately there are no WordPress hooks to put a script after <body> HTML tag

    Cheers

    IntellyWP

    Oh, bummer. Hopefully you can figure something out to get code inserted right after <body>, or as close after as you can. Some code (e.g. Google Tag Manager) has some snippets that want to be inserted close to <body>.

    Thanks,
    -Norm

    Plugin Author IntellyWP

    (@intellywp)

    Hey Norm

    We will try to add this feature in a next plugin update.

    We will contact you in this case.

    Cheers

    IntellyWP

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘After placement not positioned correctly’ is closed to new replies.