Support » Plugin: Widget Logic » After Activating the plugin, my site crashed…!

  • Below is the error code which I get on my Index page of my site right after the installation of Widget Logic.

    Warning: Illegal offset type in /home/ciwce/public_html/wp-content/plugins/widget-logic/widget_logic.php on line 151

    Warning: Illegal offset type in isset or empty in /home/ciwce/public_html/wp-content/plugins/widget-logic/widget_logic.php on line 154

    Warning: Illegal offset type in /home/ciwce/public_html/wp-content/plugins/widget-logic/widget_logic.php on line 151

    Warning: Illegal offset type in isset or empty in /home/ciwce/public_html/wp-content/plugins/widget-logic/widget_logic.php on line 154

    please guide me to fix this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor alanft

    (@alanft)

    can you confirm the version you are using (and if it’s not the latest, please update and let me know what happens)

    yeah it is the Latest version & updated one.

    same here.
    site crashed. wp v3.1.1.

    Plugin Contributor alanft

    (@alanft)

    I think what’s happening is some widget is not behaving as expected. I have a suggested fix for you, but it would be useful to know what widget making plugins you are both using too.

    after line 150 “$id=array_pop($params);”, insert this extra line:

    if (!is_string($id)) return;

    which I think will have the effect of always hiding problematic widgets. Let me know how that works out for you.

    Well, the error got away not now I can only see the middle section. The left and right panels went away too..

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘After Activating the plugin, my site crashed…!’ is closed to new replies.