WordPress.org

Forums

Easy Modal
[resolved] Adding Modal To Certain Post Only? (4 posts)

  1. jiipsijack
    Member
    Posted 1 year ago #

    Hi there, I've just installed the latest free version of easy modal and it has been so useful so far, really great plugin, so thanks for that.
    One issue I'm having trouble with is adding a Modal to a post, Its not set to site wide but I don't get the option on the post to select which modals to add (the box down the bottom) this appears fine on pages so I'm just wondering is this capability something that should be there but isn't? or is it reserved for the pro version of the plugin? (I see mention of per page/post in the feature list) or as a third option, is this supposed to be there but isn't because I'm using a custom post type?

    Look forward to you shedding some light on this. Thanks in advance.

    https://wordpress.org/plugins/easy-modal/

  2. danieliser
    Member
    Plugin Author

    Posted 1 year ago #

    It should work for both pages and posts. If you have a custom post type there is a filter you can hook and add your CPT.

    Check it out here

    Please take a moment to rate and review the plugin and or support here

  3. jiipsijack
    Member
    Posted 1 year ago #

    Cheers, that worked perfectly, I don't know how I missed that thread when I was searching! there is a small typo in that code that throws an error but it was a quick fix, the first instance of "my_cpts" is fine but the second says "my_opts" just for anyone else who uses it, you may wanna update that thread. Thanks for the super fast support and the great plugin, I'll be reviewing it now. 5 stars on their way!

  4. ashutosh_dixit
    Member
    Posted 1 year ago #

    Hello,
    Thanks for such a nice plugin. BUt one thing i want to know is it possible that modal loads only to that page where it is needed not side wide, because making side wide option on is causing trouble to page loading time of the website as i have more than 200 modal in my website and all the models are getting load on home page so its making my site to load slower.....

    Thanks in advance for the solution

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Easy Modal
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.