• Resolved officezen

    (@officezen)


    I receive the following error upon selecting “Add New Event”

    Warning: http_build_query(): Parameter 1 expected to be Array or Object. Incorrect value given in /home3/bluemoun/public_html/_new/wp-includes/Requests/Transport/cURL.php on line 508

    PHP version: 5.6

    The error usually goes away upon page refresh.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi @officezen,

    The PHP version is ok. Be sure to update to the latest version of our plugin which is 2.5.19. The error may also be cause by a plugin conflict.

    Please disable all plugins, temporarily, and then check if the problem recurrs — then re-enable each one until you find which one caused the problem.

    Thread Starter officezen

    (@officezen)

    Disabled all plugins and still receives the error, which goes away on page refresh.

    I’m using the latest 2.5.19.

    Thread Starter officezen

    (@officezen)

    It’s not the theme, either, as I received the same error in the backend even when I’m using Twenty-Sixteen theme.

    @officezen do you have the WP Smush plugin installed?

    Thread Starter officezen

    (@officezen)

    I do, but I still see the same error even after I disabled it.

    Thread Starter officezen

    (@officezen)

    It looks like I’m not the only one experiencing this error:

    https://ideas.time.ly/ideas/CAL-I-432

    @officezen:

    That post is from August 29, 2016.
    A resolution was posted right on that page on Dec 5, 2016:

    ADMIN RESPONSE

    Hey everyone!

    After a lot of research, the http_build_query has finally been fixed in the version 2.5.14. We’ve found that on some very specific installations, the PHP object conversion wouldn’t work as expected before calling our API, causing the reported error.

    Aristotel

    The bug was fixed in a previous release. If you still get this error, I suggest a manual reinstall of the calendar:

    – Perform a complete back up of your database before proceeding further
    – Delete the file uninstall.php from the plugin directory that is currently on the server (found under /wp-content/plugins/all-in-one-event-calendar). Deleting this file ensures that when you uninstall the current version of the plugin, your event data and calendar settings will be preserved when you delete the plugin (don’t skip this step – it’s important!)
    – Deactivate the All-in-One Event Calendar using your WordPress Dashboard.
    – Delete the All-in-One Event Calendar using your WordPress Dashboard.
    – Database -> wp_options, click option_name to sort and delete everything with ai1ec_, this will delete plugin settings but events will remain in the database.
    – Now install the latest version.

    • This reply was modified 9 years, 4 months ago by Sunny Lal.
    Thread Starter officezen

    (@officezen)

    Why are there so many users who stated they are still experiencing the same issue way after you posted the possible resolution on Dec 5, 2016 on that page?

    @officezen, the bug was fixed in version 2.5.18.

    Thread Starter officezen

    (@officezen)

    Sunny,

    I followed all of your instructions as noted above and reinstalled the plugin. The error still persists.

    What now?

    @officezen: I have to investigate further, to do that, please log into your Timely account and open a ticket by clicking on the Get Help link, or click here: https://dashboard.time.ly/account/get-help.

Viewing 11 replies - 1 through 11 (of 11 total)

The topic ‘Add New Event warning’ is closed to new replies.