Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Add donation form throws everal errors

  • Resolved johnzoet1

    (@johnzoet1)


    I am testing GiveWP on my local workstation before moving to the prod server.
    Went to all setup steps before adding first donation form.
    Plugin throws immediately zillions of errors before and after the form configuration.

    ( ! ) Warning: array_intersect_key(): Expected parameter 1 to be an array, string given in D:\xampp\htdocs\mokopuna.cloud\wp-content\plugins\autodescription\inc\classes\post-data.class.php on line 116

    ( ! ) Warning: Invalid argument supplied for foreach() in D:\xampp\htdocs\mokopuna.cloud\wp-content\plugins\autodescription\inc\classes\post-data.class.php on line 121

    ( ! ) Warning: array_merge(): Expected parameter 2 to be an array, null given in D:\xampp\htdocs\mokopuna.cloud\wp-content\plugins\autodescription\inc\classes\post-data.class.php on line 125

Viewing 3 replies - 1 through 3 (of 3 total)
  • After publishing form the resulting donation form was not right.
    Went to menu “All Forms” , Click on Edit, now all errors are gone and form looks ok.
    Tested form in test mode and donation shows up under Donations.

    Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi @johnzoet1,

    Those errors are all referencing a plugin called “autodescription” so in troubleshooting this issue, that’s where I’d start.

    It sounds from your follow-up message that things are working now. Let us know if that’s not the case. We’re happy to have a look.

    johnzoet1

    (@johnzoet1)

    Hi @benmeredithgmailcom,

    I could finf plugin autodescription by WP CLI command :
    wp plugin list

    | so-css | inactive | none | 1.2.4 |
    | autodescription | active | none | 4.0.2 |
    | updraftplus | active | none | 1.16.17 |

    This is “The SEO Framework” plugin.
    Tested this was the right plugin with:
    wp plugin deactivate autodescription

    Now, the plugin was inactive in the plugin list.

    Having said that, the GiveWP plugin works fine now even with “The SEO Framework” plugin enabled.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.