Support » Plugin: Swim Team » Activate problem

  • Dear,

    i have a problem when i try to activate the plugin:

    WordPress version: 4.6.1
    phpHtmlLib 2.6.8.3578
    wp-swimteam: 1.45.1085

    work flow:
    download and activate phpHtmlLib: ok
    download and activate wp-swimteam: wrong.

    
    Warning: Declaration of FooterNav::push($url, $text) should be compatible with Container::push() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\FooterNav.inc on line 289
    
    Warning: Declaration of FooterNav::add($url, $text) should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\FooterNav.inc on line 289
    
    Warning: Declaration of ImageThumbnailWidget::push($url, $text, $selected = false) should be compatible with Container::push() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\ImageThumbnailWidget.inc on line 688
    
    Warning: Declaration of NavTable::push($url, $text, $title = NULL, $target = NULL) should be compatible with Container::push() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\NavTable.inc on line 313
    
    Warning: Declaration of NavTable::add($url, $text, $title = NULL, $target = NULL) should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\NavTable.inc on line 313
    
    Warning: Declaration of TabList::add(&$tab_obj) should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\TabWidget.inc on line 658
    
    Warning: Declaration of TextNav::push($url, $text, $width = 100) should be compatible with Container::push() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\TextNav.inc on line 184
    
    Warning: Declaration of TextNav::add($url, $text, $width = 100, $target = NULL) should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\TextNav.inc on line 184
    
    Warning: Declaration of TextCSSNav::push($url, $text, $title = '', $target = '') should be compatible with Container::push() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\TextCSSNav.inc on line 229
    
    Warning: Declaration of TextCSSNav::add($url, $text, $title = '', $target = '', $selected = false) should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\TextCSSNav.inc on line 229
    
    Warning: Declaration of VerticalCSSNavTable::add($url, $text, $title = '', $target = '') should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\VerticalCSSNavTable.inc on line 197
    
    Warning: Declaration of ErrorBoxWidget::add($label, $message) should be compatible with Container::add() in C:\xampp\htdocs\ivan\wp-content\plugins\phphtmllib\widgets\ErrorBoxWidget.inc on line 96
    
    Fatal error: Redefinition of parameter $swimmerid in C:\xampp\htdocs\ivan\wp-content\plugins\wp-swimteam\class\swimmeets.class.php on line 2384
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    What version of PHP is your server using?

    Hi,

    PHP 5.6

    Regards,

    i’m sorry i made a mistake, the php version is 7.0.3

    regards,

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Ok, that makes a lot more sense. I’ve run all of that code in PHP5.x but never in PHP7.x. It was all originally written in PHP4 (not by me, I just used the library). Getting it cleaned up for PHP7 is likely a fair amount of work that I am not sure I will be able to carve out time to do.

    Are you able to run PHP5.x instead?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Activate problem’ is closed to new replies.