Support » Plugins » [Plugin: Absolute Privacy] 2.0.6 breaks

  • Resolved mev

    (@mev)


    An update to Absolute Privacy 2.0.6 was just sent out.

    This causes my blog page to get the following error when I try to log in:

    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /homepages/19/d152872219/htdocs/bike2013/wp-content/plugins/absolute-privacy/functions.php on line 841

    After that I am not able to log in. This is using WordPress 3.3.1.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same problem after completing the upgrade to V2.0.6 & cannot login to my site.
    When I login as Admin, the following popup appears.:-

    Warning: array_key_exists() expects parameter 2 to be array, null given in /home/XXXXXXXX/public_html/wp-content/plugins/absolute-privacy/functions.php on line 841

    Warning: Cannot modify header information – headers already sent by (output started at /home/XXXXXXXX/public_html/wp-content/plugins/absolute-privacy/functions.php:841) in /home/XXXXXXXX/public_html/wp-includes/pluggable.php on line 669

    Warning: Cannot modify header information – headers already sent by (output started at /home/XXXXXXXX/public_html/wp-content/plugins/absolute-privacy/functions.php:841) in /home/XXXXXXXX/public_html/wp-includes/pluggable.php on line 670

    Warning: Cannot modify header information – headers already sent by (output started at /home/XXXXXXXX/public_html/wp-content/plugins/absolute-privacy/functions.php:841) in /home/XXXXXXXX/public_html/wp-includes/pluggable.php on line 671

    Warning: Cannot modify header information – headers already sent by (output started at /home/XXXXXXXX/public_html/wp-content/plugins/absolute-privacy/functions.php:841) in /home/XXXXXXXX/public_html/wp-includes/pluggable.php on line 866

    I am also using the latest version of WordPress.

    My apologies. This issue did not come up in testing at all. I’ve just fixed this (and I did a quick scan to see if it would crop up anywhere else).

    But Warnings in general shouldn’t be keeping you from logging in … so if you’re getting a “Cannot modify header information” warnings, you might have WP_DEBUG set to true.

    I wasn’t able to reproduce this issue locally … so please test version 2.0.7 immediately and let me know if it resolves the issue.

    The issue may be rectified in v2.0.7 but the problem of being able to login the the URL remains. Until I can login, I’m unable to install the new version.

    I can FTP to the site & view the files. Is it possible to disable the plugin to let me login to install the update?

    Symptoms I reported have been addressed with v2.0.7.

    I was fortunate to have had a different computer still logged in or else I would have had similar symptoms as coolobill on not being able to log in to turn things off.

    Thanks

    It’s all sorted…………

    I was able to FTP to the site & temporarily rename the directory:-

    /www/wp-content/plugins/absolute-privacy

    That allowed me to login & do the upgrade to v2.0.7 & now all is rosy in the garden……

    I’m back in. 🙂

    Glad we were able to sort things out. Once again, my apologies for the error. Not sure why it didn’t trigger any issues during testing 🙁

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Absolute Privacy] 2.0.6 breaks’ is closed to new replies.