Support » Plugin: WordPress Backup and Migrate Plugin - Backup Guard » 64 bits integer support by PHP

  • Resolved magicphotoevents

    (@magicphotoevents)


    Hello,

    I have an error message when I attempt to configure a dropbox storage access :

    The Dropbox SDK uses 64-bit integers, but it looks like we’re running on a version of PHP that doesn’t support 64-bit integers (PHP_INT_MAX=2147483647). Library: “/home/xxxxxxxx/www/wordpress/wp-content/plugins/backup-guard-silver/com/lib/Dropbox/RequestUtil.php”

    I also have a similar error message in the log file when I attempt to make a manual backup :

    2018-01-03 15:27:00: SGExceptionIO: BackupGuard uses 64-bit integers, but it looks like we’re running on a version of PHP that doesn’t support 64-bit integers (PHP_INT_MAX=2147483647) [File: /home/xxxxxxxxxx/www/wordpress/wp-content/plugins/backup-guard-silver/com/core/SGBoot.php, Line: 223, URL: /wordpress/wp-admin/admin-ajax.php]

    The host of my website tell me that PHP is already in 64 bits version !

    Here’s the phpinfo output :

    PHP Version 5.6.31
    System Linux webd205.300gp.ha.ovh.net 4.4.67-ovh-vps-grsec-zfs-classid #1 SMP Thu May 11 18:47:35 CEST 2017 x86_64
    Build Date Sep 21 2017 10:21:33
    Configure Command ‘./configure’ ‘–with-openssl’ ‘–with-mysql=mysqlnd’ ‘–with-mysqli=mysqlnd’ ‘–with-pdo-mysql=mysqlnd’ ‘–prefix=/usr/local/php5.6’ ‘–enable-fpm’ ‘–enable-opcache’ ‘–enable-memcache’ ‘–enable-memcached’ ‘–enable-redis’ ‘–with-gd’ ‘–enable-intl’ ‘–enable-gd-native-ttf=/usr’ ‘–with-png-dir=/usr’ ‘–enable-wddx’ ‘–with-config-file-path=/usr/local/php5.6/etc’ ‘–enable-sigchild’ ‘–enable-short-tags’ ‘–disable-rpath’ ‘–enable-libgcc’ ‘–with-zlib=/usr’ ‘–enable-bcmath’ ‘–enable-calendar’ ‘–with-curl=/usr’ ‘–with-gdbm=/usr’ ‘–enable-ftp’ ‘–with-gettext=/usr’ ‘–with-imap’ ‘–with-kerberos’ ‘–with-imap-ssl’ ‘–with-mcrypt=/usr’ ‘–with-mhash=/usr’ ‘–with-jpeg-dir=/usr’ ‘–enable-exif’ ‘–with-regex=system’ ‘–enable-sysvsem’ ‘–enable-sysvshm’ ‘–enable-sysvmsg’ ‘–enable-zip’ ‘–enable-inline-optimization’ ‘–enable-soap’ ‘–enable-mbstring’ ‘–enable-mbregex’ ‘–with-gnu-ld’ ‘–with-libxml-dir’ ‘–enable-shared=yes’ ‘–enable-static=yes’ ‘–with-xsl=/usr’ ‘–enable-sockets’ ‘–with-xmlrpc’ ‘–with-iconv’ ‘–with-imagick’ ‘–enable-pdo’ ‘–with-pdo-pgsql=/usr’ ‘–enable-mongo’ ‘–with-xpm-dir=/usr’ ‘–with-pcre-regex’ ‘–with-freetype-dir=/usr’ ‘–with-pspell’ ‘–with-pgsql=/usr’ ‘–with-bz2’ ‘–with-gmp’ ‘–enable-igbinary’ ‘–enable-memcached-igbinary’ ‘–enable-memcached-json’ ‘EXTENSION_DIR=/usr/local/php5.6/lib/php-extensions’
    Server API FPM/FastCGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /usr/local/php5.6/etc
    Loaded Configuration File /images/jessie.i386/usr/local/php5.6/etc/php-fpm.ini
    Scan this dir for additional .ini files (none)
    Additional .ini files parsed (none)
    PHP API 20131106
    PHP Extension 20131226
    Zend Extension 220131226
    Zend Extension Build API220131226,NTS
    PHP Extension Build API20131226,NTS
    Debug Build no
    Thread Safety disabled
    Zend Signal Handling disabled
    Zend Memory Manager enabled
    Zend Multibyte Support provided by mbstring
    IPv6 Support enabled
    DTrace Support disabled
    Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2
    Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, mcrypt.*, mdecrypt.*

    What is wrong please ?

Viewing 1 replies (of 1 total)
  • Plugin Author Backup Guard

    (@backupguard)

    @magicphotoevents Firstly this exception comes from Dropbox SDK which requires to have 64Bit running Operating Systems. Actually, there’s no workaround for this at this moment.The only solution is to have 64Bit OS to be able to use Dropbox feature. As this limitation comes from Dropbox, but not BackupGuard, we’re unable to do much about that.

    Secondly In 32 bit Operating System where max allowed archive size is 2Gb. As far as your website is larger than 2Gb, that’s why you see the following exception in the log:

    SGExceptionIO: BackupGuard uses 64-bit integers, but it looks like we’re running on a version of PHP that doesn’t support 64-bit integers…

    This limitation is applied by your server, and has nothing to do with the BackupGuard plugin.Only on 64 bit running Operating Systems allow archives/files larger than 2Gb.

    However, we recommend you to split the backup into several parts (e.g. backup your database, uploads, plugins, themes separately). This will help to decrease the archive size and won’t let it exceed 2Gb.

    Please ask your hosting provider to duble check on what operating system there servers is running. We are prity sure that it is 32bit system.

Viewing 1 replies (of 1 total)
  • The topic ‘64 bits integer support by PHP’ is closed to new replies.