Support » Plugin: User Switching » 502 error

  • I’ve read all of the previous posts in regards to receiving the 502 error on the User Switching functionality. It appears the functionality does work when I use the ‘Switch To’ functionality locally through Chrome. I get the 502 error when going through IE and FireFox.

    My site is hosted through Network Solutions. They did confirm it’s positioned on a shared server running NGINX. Site is running PHP 7.2.20.

    Users have used this functionality in the past and didn’t experience these types of issues. Other users getting errors when running through multiple browsers. I’ve attempted to clear the cache on browser before all attempts.

    Any other suggestions as to what might be causing these 502 errors.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Thanks for the report. I also see this issue myself occasionally but I’ve not pinned it down. Clearing all your cookies tends to help, but the same error can be encountered again if your other cookies build up.

    I’m going to see if I can reduce the size of the User Switching cookies. It’s not really the root cause, but it should alleviate the problem for those people who are seeing this issue.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    By the way, if you look at the error log on your site, you should be able to see the cause of the 502. It’s most likely a upstream sent too big header or similar, which means the site is setting too many cookies and other headers.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.