WordPress.org

Support

Support » Plugins and Hacks » [Resolved] 500 Internal Server Error

[Resolved] 500 Internal Server Error

  • After installing your plugin Gzip Ninja version 0.0.3, I got a 500 Internal Server Error. I don’t know how to fix that. I already removed your plugin via FTP, but that didn’t work. I also contacted my Hosting provider but they said it is something with the .htacces file, but I don’t know how to fix that. Can you give me some help?

    Butsie

    http://wordpress.org/plugins/gzip-ninja-speed-compression/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author CustomWPNinjas

    @customwpninjas

    Hey Butsie,

    I’d be happy to help! Sorry you had an issue.

    Normally what that means is that your hosting company is restrictive. Care to email me?

    ninjas [at] customwpninjas.com

    we can discuss your URL and a specific way to fix it. If you can navigate to your FTP you can open your .htaccess file and paste this in

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    That should get it back up. Now we just need to figure out how to GZip your stuff.

    Plugin Author CustomWPNinjas

    @customwpninjas

    OK, thank you for providing me FTP access so I could fix this.

    Your hosting company has a .htaccess file in your /home/ directory that was causing a conflict with your WordPress install. GZip Ninja Speed may have brought that issue out in the open, but it certainly is not at all a standard install that this was going under.

    Problem solved and I am very thankful you tried our plugin. I have also installed leverage browser caching for you. Please do not reinstall this plugin as it has already been manually applied to your .htaccess

    Thank you very much for your time to fix this problem. I know now that it was a mistake from the hosting provider and not a plugin issue.
    Thanks.

    I got the same problem but in my case this didn’t help at all.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I have put my site back online when I have deleted .htaccess because and my dashboard didn’t work either and then I have disabled the plug-in.

    Plugin Author CustomWPNinjas

    @customwpninjas

    What is your URL?

    Are you apache based? Send me an email too at ninjas [at] customwpninjas.com we can solve right now.

    http://prismabg.com
    Yes the host is Apache based.

    Ok.

    I will send you data for access to the site.

    Plugin Author CustomWPNinjas

    @customwpninjas

    Ok, I have solved! It turns out, your server does not have mod_deflate installed – which is … very weird.

    Any server would LOVE to have someone compress their data, it means less bandwidth they are responsible for transferring.

    Also, you put your .htaccess file in the wrong place. You put in site root, it should have went (in your file structure) on /www/root/ (you had it before the www)

    Ok – last thing – I have manually installed Leverage Browser Caching for you as well, do not activate a plugin that does that.

    You should consider moving hosting companies. [hosting link moderated] – that’s us and we help our customers quick 🙂

    Thanks for the help.

    I will consider the hosting for my future projects.

    esmi

    @esmi

    Forum Moderator

    @customwpninjas: Please do not use these forums to promote your own hosting services.

    Plugin Author CustomWPNinjas

    @customwpninjas

    @esmi My bad! Just thought it would help kill the proverbial two birds with one stone issue 🙂

    LONG LIVE THE NINJA! (long live the moderator)

    esmi

    @esmi

    Forum Moderator

    I do understand why you might want to ensure that your users are on the best server platform for your plugin but the problem we have is that, if we let one hosting company promote/mention their hosting, we’d have a flood in no time.

    Thank you very much for understanding. 🙂

    Help! Same issue here, and adding the code to the .htaccess file didn’t work. Still an internal server error when trying to access my clients WP site.

    same issue : here is my .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    # GZip Ninja Speed -- Starts here
    # Do not write anything between "GZip Ninja Speed -- Starts" and "GZip Ninja Speed -- Ends"
    # It will be deleted while uninstalling GZip Ninja Speed plugin
    AddOutputFilterByType DEFLATE text/plain #GZip Ninja Speed
    AddOutputFilterByType DEFLATE text/html #GZip Ninja Speed
    AddOutputFilterByType DEFLATE text/xml #GZip Ninja Speed
    AddOutputFilterByType DEFLATE text/css #GZip Ninja Speed
    AddOutputFilterByType DEFLATE application/xml #GZip Ninja Speed
    AddOutputFilterByType DEFLATE application/xhtml+xml #GZip Ninja Speed
    AddOutputFilterByType DEFLATE application/rss+xml #GZip Ninja Speed
    AddOutputFilterByType DEFLATE application/javascript #GZip Ninja Speed
    AddOutputFilterByType DEFLATE application/x-javascript #GZip Ninja Speed
    AddType x-font/otf .otf #GZip Ninja Speed
    AddType x-font/ttf .ttf #GZip Ninja Speed
    AddType x-font/eot .eot #GZip Ninja Speed
    AddType x-font/woff .woff #GZip Ninja Speed
    AddType image/x-icon .ico #GZip Ninja Speed
    AddType image/png .png #GZip Ninja Speed
    # GZip Ninja Speed -- Ends here

    When I delete ninja codes (2nd part) its working. Is that necessary ?

    Plugin Author CustomWPNinjas

    @customwpninjas

    The reason that it is failing is your server / hosting company has in some way limited your website from allowing it. Send me an email, we can talk about what other options you have privately.

    I just emailed you. Having similar issue

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] 500 Internal Server Error’ is closed to new replies.