Support » Fixing WordPress » 500 Internal Server Error……….

  • Resolved youthmanPTB

    (@youthmanptb)


    Hi there.

    Iv run into a problem trying to get my domain name (www.promotethebass.co.uk) to work with my website (hosted with justhost). Iv tryed googling it and cant find the right info that can help me and now im getting a 500 Internal Server Error on my pages (not home page) after attempting a tutorial :/

    I try give all the info on my situation because its a little complicated.

    So, I purchased a domain name (promotethebass.co.uk) with a Uk-Cheapest which was directed to a google site website i made.

    Google site was not that good to use so i decided to buy so hosting space with Justhost and then use wp to build a new site.

    wp is installed fined, iv set up a theme i like and have it looking how i want and Iv pointed the domain to Justhost servers. coolio

    When typing in my domain (www.promotethebass.co.uk) into the address bar it worked fine and took me to the wp site i built, but I noticed when i clicked to a another page of my site or logo i the address changed to and ip.

    So i looked for a solutiona and coundnt find much that i could understand or anything that seemed like it would solve this problem.

    I found one tutorial on wp site titled “Changing The Site URL”

    codex.wordpress.org/Changing_The_Site_URL

    which sounded like the answer. Followed the first 2 step “Edit wp-config.php ” and “Edit functions.php”. First step didnt do much in helping when applied, only making my site text based or somethink so i changed it back no problem. Applied the second method and what do you know it WORKED!!! so the home page is working with my domain name BUT when i click on my other pages they display 500 Internal Server Error

    This is the point iv reach in my attepted to get my site running correclty. Please advise on what i have done wrong or what i should of done.

    Big thank you in advanced 🙂

Viewing 15 replies - 1 through 15 (of 21 total)
  • esmi

    (@esmi)

    Forum Moderator

    How log ago did you make the nameserver changes?

    I made it 4days ago

    esmi

    (@esmi)

    Forum Moderator

    If you used the functions.php method, did you remove the added lines after loading up the site at the new url?

    I did yes

    esmi

    (@esmi)

    Forum Moderator

    Try switching to the Twenty Eleven theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    I dont have Tweenty Eleven them installed. Should i use the Tweentyten instead?

    esmi

    (@esmi)

    Forum Moderator

    If you are running WordPress 3.4.2, then you should ALWAYS have an unedited copy of the Twenty Eleven theme installed. Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentyeleven

    Ok so Tweenty Eleven is installed and iv renamed my current theme to Tweenty Eleven with -old on the end of it

    esmi

    (@esmi)

    Forum Moderator

    Nooo! Rename your old theme’s folder to old-theme.

    Ok sorry but maybe im not understanding your instructions very well.

    Add “-old” on to the end of my current themes names…
    Is this correct? or do you want me to active the Tweenty Eleven theme?

    sorry to be a pain

    esmi

    (@esmi)

    Forum Moderator

    Is this correct?

    Yes. This will activate Twenty Eleven automatically.

    Ok cool. So in my admin panel shows that Twenty Eleven is activated. On my webpage all i see is a white screen with nothink on.

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    So i deactivating all plugins and it now i see the Tweenty Eleven theme working.

    Just activated the plugins i was using and there seems to be no problem no problem with viewing the webpages

    Should i try reactivat the other theme i was using?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘500 Internal Server Error……….’ is closed to new replies.