Support » Plugin: All In One WP Security & Firewall » 404s Not Being Logged

  • Resolved svacontact

    (@svacontact)


    For some reason, AIOWPS has completely stopped logging 404 errors. I can still see them in the server access logs, but not on the Firewall 404 page. I tried disable/enable and no change. Any ideas what may have happened?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Did you try to reinstall the plugin? If not can you try that please.

    Also did you carry out any updates on your site before you notice this issue?

    Thank you

    • This reply was modified 2 years, 8 months ago by  mbrsolution.

    Thanks for the reply. I found the issue. I had made some changes to the theme’s 404.php file which in my opinion was (1) too large for something that gets served a lot and (2) full of source information that I wasn’t thrilled about sharing with folks trolling for the login page. Without going into detail, I found the code that has to be present for AIOWPS to log the 404s and created a 404.php that returns 76 bytes (vs 27000) and doesn’t convey any unnecessary information.

    As a possible enhancement request, it would be cool if AIOWPS could provide an option for those with Rename Login enabled to serve a minimal 404 response to attempts to access wp-login.php and a more “user friendly” one for logged in users.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    I am happy to know that you found a solution to your problem. I will mark this support thread as resolved.

    In regards to your request, the plugin developers will investigate further.

    Thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘404s Not Being Logged’ is closed to new replies.