Support » Plugin: BackUpWordPress » 404 errors

  • Resolved Thor.worx


    Can not get to backups/settings page

    Seems to be a namespace problem.
    Any attempts to get to settings results in 404 errors (even clicking on the plugin details on the plugins page results in a 404 in the popup).

    Only plugin on a fresh install of WP.
    php 5.6
    All permissions are correct.

    I’ve never had this issue on any other install of HMBK before.

    Any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author katmoody


    Are you able to uninstall and then reinstall the BackUpWordPress plugin from the repo? I’ve not seen this before either πŸ™ Sometimes the craziest issues tend to come from a glitch. Try reinstalling and see if the problem persists. If it does, maybe then try turning on WP-debug and see if any errors are happening?

    Let me know what you find out!

    ps – is it only the BackUpWordPress admin page and links inside that page – you don’t have the same issue throughout the WP admin?

    Hi Kat,
    Thanx for your reply…

    Yes.. I’ve un/reinstalled several times..

    I’m a developer and use the plugin on MANY of my sites with no problems.
    This particular site is on a different server… but I’m not seeing any obvious differences in the hosting environments.

    Yes, it’s ONLY backupwordpress that is affected – as I said, I have no other plugins installed, and can access everything in admin, no problem.

    In fact, I had originally installed it on an existing WP site on this server (with several other plugins) and had this problem ONLY with backupwordpress, so I created an entirely new subdomain and database just to test this. Same thing.

    Turning on debug does not give me any information… no errors.

    As an experiment, I commented out the namespace line in backupwordpress/admin/page.php
    Doing so, I was able to get the settings page… and viewing page source, I could see most of the code loaded – before throwing a fatal error when outputting the html for the page.

    Very strange.

    Plugin Author katmoody


    My own test server allows me to use php 5.6.28 but not 5.6 and I can’t replicate the issue. πŸ™

    I know that they corrected namespaces several months back because of an issue with php version 5.4. but it doesn’t sound like the same issue. The installation isn’t inside it’s own subdirectory by chance?

    No disabled php functions on this server that are different? Are you able to set up a link for me? If so you can email it to me at and I’ll see if there’s anything else I can pinpoint. The only other thing I can think of is to try running the Query Monitor plugin as well and see if any additional information is revealed using that?

    Let me know, very strange indeed!


    Hmmm… after struggling with this for about a week, I just checked this morning, and it seems to be working. As far as I know, nothing was done over the weekend on the server to “fix” this… but it IS working now.

    Very strange indeed. I’ll let you know if this issue crops up again.

    btw… you wrote:

    The installation isn’t inside it’s own subdirectory by chance?

    Yes, I do ALL of my WordPress installations in their own subdirectories. As a developer, I consider this the correct way to install WP.

    Plugin Author katmoody


    Yes, I put all mine inside their own subdirectories as well as I also consider that best practice … but what I was wondering is whether the links you observed not working properly included that subdirectory or not? Every once in a while I have to re-do permalinks or reset them, because of weird glitches like this. I’ve noticed they tend to occur more when the installation is inside it’s own subdirectory than when it is not. No idea why but just was considering whether to have you check resetting permalinks πŸ˜‰ Since its’ all good now then no worries πŸ˜€


    Yep, the subdirectory WAS included in the 404’d link.
    … and believe me, I was updating the permalinks constantly. =)

    I’ll let you know if this oddness resurfaces. Thanks for your time.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘404 errors’ is closed to new replies.