WordPress.org

Support

Support » Plugins and Hacks » Rename wp-login.php » [Resolved] 404 error on login page

[Resolved] 404 error on login page

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Ella van Dorpe

    @iseulde

    That’s really weird. Can you log in properly?
    What other plugins do you have installed and what other customisations have you added to the login form?
    .htaccess is not the problem, the plugin doesn’t use it.

    Yup, can login properly through the desktop version. We also have a mobile version – logging in via the mobile version doesn’t work. I’m using Custom Login 2.0 to make customizations to the login form – though they are only aesthetic (i.e. logo, colors, etc).

    Here is a list of plugins that I’m using that might cause an issue with the login form:

    Custom Login 2.0
    Page Security By Contexture
    WPTouch Pro
    WordPress HTTPS

    Plugin Author Ella van Dorpe

    @iseulde

    It’s really difficult to find out the cause without having access to it, not sure if we’ll find it. I haven’t tested this plugin on websites that enforce HTTPS or multisite (see description), so I can’t guarantee that it would work, but atm I don’t see a reason why it wouldn’t on HTTPS.
    Could you deactivate and activate the plugins you mentioned one by one and look at the login form to see if it’s still there?

    Plugin Author Ella van Dorpe

    @iseulde

    I tested Custom Login – not the problem.
    Looked into WPTouch (the free version) and they hardcoded the link in their login form (and also their comment form!): <?php site_url(); ?>/wp-login.php. Plugins and themes should use <?php echo wp_login_url(); ?> so other plugins can hook in this function to modify it. I recommend asking them to fix it, I can’t do anything about it.
    So that’s your mobile problem, I’ll continue looking into the 404 problem.

    Yup- already fixed the mobile issue 🙂

    Thanks for looking into this!

    Plugin Author Ella van Dorpe

    @iseulde

    I’ve already created a support ticket there http://wordpress.org/support/topic/dont-hardcode-wp-loginphp

    Plugin Author Ella van Dorpe

    @iseulde

    WordPress HTTPS also has wp-login.php hardcoded twice, not sure if that’s the problem. Have you tried deactivating this one yet?
    Btw, I don’t recommend changing plugin files, but if you do, I’m sure you know the changes are gone next time you update.

    Plugin Author Ella van Dorpe

    @iseulde

    If you can change the files, could you go to this plugin’s folder (rename-wp-login) and add a line to the file wp-login.php?
    On line 151 you’ll see
    } // End of login_header()
    Just before that line, add
    var_dump($wp_error);
    Then go to your login form ad you’ll see some raw data under the error. Copy paste that here. Then go back to the file and remove the line you added. If you accidentally removed or added something else, delete the plugin and reinstall it.

    Will check this out today at some point. Thanks for being on top of this. Sorry for being slow on my end!

    I added the var_dump as you said. All I see at the top right corner is a “NULL”:

    http://cambridgerunning.org/crc-login

    Probably doesn’t help that much. I’ll see if I can disable some of the plugins and through the process of elimination figure out if there are any culprits that may be causing the “404” error to show up.

    Plugin Author Ella van Dorpe

    @iseulde

    That’s really weird… Yes, update WordPress and this plugin to the latest version and try deactivating your plugins one by one and see if it’s still there. It might have something to do with the fact that you use https, I still have to test the plugin for that, but I don’t have the means to do that right now.

    So I disabled plugins one by one and the 404 error is still there.

    My guess would be is that it’s a server-side issue.. hence a ‘404 error’. The server that’s hosting my site is running on IIS (yea.. I know), so perhaps it’s not smart enough or not happy with the URL redirection of wp-login.php – any advice on configuring a .htaccess to make it go away? Or alternatively, should I contact my hosting company and ask them if there is anything on their end that’s causing this problem?

    So I disabled plugins one by one and the 404 error is still there. The only time it disappears is when I disable your plugin 🙁

    My guess would be is that it’s a server-side issue.. hence a ‘404 error’. The server that’s hosting my site is running on IIS (yea.. I know), so perhaps it’s not smart enough or not happy with the URL redirection of wp-login.php – any advice on configuring a .htaccess to make it go away? Or alternatively, should I contact my hosting company and ask them if there is anything on their end that’s causing this problem?

    I really think it’s an issue with IIS to be honest.

    I have an .htaccess file with RewriteEngine On, but it does nothing since .htaccess is only used on Apache. Perhaps you can try replicating the bug on your environment without having mod_rewrite enabled on your apache configuration?

    I’ve contacted my hosting company – will get back to you once I hear back from them.

    Plugin Author Ella van Dorpe

    @iseulde

    I really don’t have any experience with IIS… But, I agree that it’s definitely the issue. You have permalinks of the structure example.com/index.php/post-title/. I didn’t notice that before… Have you ever tried https://www.cambridgerunning.org/index.php/crc-login/ ? Because that just works! 🙂
    The only problem is that all the links point to https://www.cambridgerunning.org/crc-login/ … I’m not sure why it’s necessary to have index.php there.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] 404 error on login page’ is closed to new replies.
Skip to toolbar