WordPress.org

Support

Support » Plugins and Hacks » Gecka Submenu » 3.8.1 Problems

3.8.1 Problems

  • After upgrading to 3.8.1 the plugin stopped working on one of our sites. The problem for us was in Submenu.php on line 157. Here the plugin checks if the global post object is of type stdClass. Switching this to check if the type is WP_Post instead worked and solved our problems.

    if( is_a($post, 'stdClass') && (int)$post->ID ) {
    should become
    if( is_a($post, 'WP_Post') && (int)$post->ID ) {

    https://wordpress.org/plugins/gecka-submenu/

Viewing 1 replies (of 1 total)
  • Edit: I think the file is /models/Submenu.php

    Anyway, my install has:
    if( ( is_a($post, 'stdClass') || is_a($post, 'WP_Post') ) && (int)$post->ID ) {

    I think I’ll post a new topic if I can’t get it working…

Viewing 1 replies (of 1 total)
  • The topic ‘3.8.1 Problems’ is closed to new replies.
Skip to toolbar