Support » Fixing WordPress » 3.6.1 update error

  • Resolved purplenaartjie

    (@purplenaartjie)


    I got the following error whilst updating to 3.6.1… Help!!!

    Fatal error: Call to undefined function wp_validate_redirect() in /home/fleursfl/public_html/wp-includes/functions.php on line 1305

    Sophie

Viewing 15 replies - 1 through 15 (of 23 total)
  • Krishna

    (@1nexus)

    Member

    Switch to Twenty Thirteen theme with all plugins deactivated and try again. Make sure that you have a recent backup of your site before updating.

    purplenaartjie

    (@purplenaartjie)

    I can’t change to 1213 or deactivate plugins. Neither can I get anywhere on the website. Whatever I do now I get the same error message. There is nothing I can do within the site or my dashboard.

    Krishna

    (@1nexus)

    Member

    Use FTP or your hosting cPanel to rename the plugins folder (add -HOLD to the folder name). Similarly, rename all themes except 2013 so that your site will open using that theme. You can login after that.

    divydovy

    (@divydovy)

    I have the same issue.

    Theme: WooThemes Function
    Plugins:

    Antispam Bee
    Features
    Google Analytics for WordPress
    Gravity Forms
    Groups
    InfiniteWP – Client
    Jetpack by WordPress.com
    jQuery Vertical Mega Menu
    The Events Calendar
    The Events Calendar PRO
    WooCommerce
    WooCommerce – Gravity Forms Product Add-Ons
    WooCommerce SagePay Form Gateway
    WooSlider
    WooThemes Updater
    WordPress Importer
    WordPress SEO

    Haven’t diagnosed cause yet but thought this list might help centralise discussion. Will update once a fix/cause is located.

    Sunder Deep Dasna

    (@shashank-mukherjee)

    plugin “WooCommerce – Gravity Forms Product Add-Ons” creates problem.

    Any solutions?

    Krishna

    (@1nexus)

    Member

    @divydovy,
    Please start your own topic.

    How-To and Troubleshooting

    Krishna

    (@1nexus)

    Member

    @shashank Mukherjee,
    Please start your own topic.

    purplenaartjie

    (@purplenaartjie)

    Thanks Krishna… I’ve restored from my backup and will wait and watch to see if the reported errors on 3.6.1 calm down a bit…

    Sophie

    jenx67

    (@jenx67)

    I updated to 3.6.1 the first day they released it. I”m on my site every day, as late as last night. Now, this morning I get a message that says an update is available: 3.6.1 and I need to update now. I already updated…how could this happen? Did some gremlins get into my site for something?

    divydovy

    (@divydovy)

    @shashank – confirmed this plugin is causing issues for us too – seems to be overriding a core function that’s now changed.

    We’ve opened a WooThemes ticket.

    @krishna: I don’t think it’s helpful to paste the same response to every thread that mentions this error. People are reporting this with a wide variety of setups even when nothing else has changed. My own take on this is that the error was introduced with:

    http://core.trac.wordpress.org/changeset/25323

    Hi,

    version 2.4.6 of “Gravity Forms Product Add-Ons” has been released and is available from WooThemes clients account page. This new version fixes the issue with WordPress 3.6.1.

    Changelog: http://www.woothemes.com/changelogs/extensions/woocommerce-gravityforms-product-addons/changelog.txt

    andrespi

    (@andrespi)

    Amazing time response of WooCommerce team. Congratulations!

    purplenaartjie

    (@purplenaartjie)

    Yep that’s the one. Annoying that Woocommerce originally informed me therewas no problem yesterday. Wasted a hell of alot of my time on this…

    quad_cities

    (@quad_cities)

    I updated to 3.6.1 and can’t search my Media Library. I am trying to retrieve already-uploaded images from the library to insert into a new post.

    The Search box does not respond when I type in a search term.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘3.6.1 update error’ is closed to new replies.