WordPress.org

Support

Support » Installation » [Resolved] 2.7.1 Problems

[Resolved] 2.7.1 Problems

  • I get a fatal error message when I try to automatically upgrade from 2.7 to 2.7.1. Is anybody else having this problem? The message I get is: Fatal error: Cannot redeclare class pclzip in /home/content/D/e/b/DebbiSmith/html/comeonsense/wp-admin/includes/class-pclzip.php on line 171. I run five sites and have the same problem with upgrades on each. I also have seen the same problem with the latest version of the DashBar plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Most people see this error when they have an older automatic upgrade plugin still installed. Deactivate and remove any old upgrade plugins.

    Otto, Thanks for the suggestion but it did not work. I have version 1.2.2 installed. I deactivated it, then removed it and re-installed using the automated process. It worked for the plugin but I got the same error message when I tried to upgrade to 2.7.1 I get the same error message on all five of the sites I am managing. Earl

    Jeremy Clark

    @jeremyclark13

    Member

    No you need to totally remove the auto upgrade plugin, and not put it back wordpress has that functionality bultin now, no need for the plugin.

    I deactivated it, then removed it and re-installed

    Wait, re-installed? What? No, you don’t *need* any plugin for upgrading. WordPress 2.7 has upgrading built into it. Those plugins are obsolete.

    Deactivate and remove any automatic upgrade plugins. Don’t reinstall them.

    AHHHHH – the sun comes up at last – thanks Otto and Jeremy – much appreiciated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] 2.7.1 Problems’ is closed to new replies.
Skip to toolbar