Support » Fixing WordPress » 2.5 Image Insert Problem (not image upload)

  • Im getting a js error while trying to insert an image
    Error: uncaught exception: Permission denied to get property Window.tinyMCE

    I can upload images fine, and browse uploaded media fine, but when i select an image, and click the “Insert Into Post” button, the pop up goes white and i get the error.

    I have tried everything suggested, reuploading the wp-admin dir, clearing cache, disabling plugins, etc…

    any suggestions?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Are you using IE? Try it in Firefox.

    If it works in FF but not in IE, then apply the IE-Fix:
    http://trac.wordpress.org/changeset/7573?format=zip&new=7573

    Im using FF
    i just tried in ie and theres a whole bunch of error which i assume the IE-fix will fix.

    any other suggestions?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    No, the IE Fix will fix a minor error, not a “whole bunch of error”.

    If you’re getting lots of errors, then your site is broken in some way. Be sure that you uploaded all the files. Really. Triple check them.

    Hey Otto42 I have the same issue but a little more info the issue only happens when my admin screens are accessed over https. And it was a fresh install. I disabled all my plugins – I did have Admin SSL installed. And the issue still occurs. I can add the ‘s’ into the protocol (in the browser bar) and see it break, take out the ‘s’, refresh and see it work.

    BTW, it’s also kind of weird that the login stays valid when you’re switching http protocols. Most apps I’ve seen require another login.

    I also applied changeset_r7573

    thx,
    K

    Here’s what safari reports
    Unsafe JavaScript attempt to access frame with URL https://<install url+dir>/wp-admin/post.php?action=edit&post=794 from frame with URL http://<install url+dir>/wp-includes/js/tinymce/plugins/media/media.htm. Domains, protocols and ports must match.

    I’m assuming Firefox is complaining about the same thing, just not as reader friendly:
    uncaught exception: Permission denied to get property Window.tinymce
    [Break on this error] undefined
    this.params has no properties
    [Break on this error] var v = this.params[n];
    tiny_mce_popup.js (line 47)
    tinyMCEPopup.editor has no properties
    [Break on this error] var themeBaseURL = tinyMCEPopup.editor.baseURI.toAbsolute(‘themes/’ + tinyMCEPop…

    Thanks,
    K

    I am also having this problem. Does it work for anyone? Or is it related to only certain installations of wordpress?

    -Bill

    This problem just showed up on my photoblog installation, after HostGator fixed another problem. I just migrated to a new domain, and it ‘happened’.
    I know all the files are fresh, I uploaded them myself less than an hour ago.

    I just uploaded all new wp-admin, wp-includes and tried all the .htaccess suggestions.

    I can upload files fine, however I cannot “insert into post”. NO matter what I do, FF says

    uncaught exception: Permission denied to get property Window.tinyMCE

    Anybody???

    Insert into post fix change line 6 in wp-admin/js/media-upload.js from tinyMCE = win.tinyMCE; to tinyMCE = parent.tinyMCE;

    Insert into post fix change line 6 in wp-admin/js/media-upload.js from tinyMCE = win.tinyMCE; to tinyMCE = parent.tinyMCE;

    nikosk.. you are a lifesaver!!! Worked perfectly!

    Thanks so much ! SteveAx

    I’m using WordPress 2.6 and have the same problem described above (pop-up box goes blank after pressing “insert into post”). The problem happens on both IE7.0 and FF2.0

    Nikosk suggests making a change in the wp-admin/js/media-upload.js file.

    My file does not have “tinyMCE = win.tinyMCE” anywhere in it. Nor is “win.” anywhere in the file.

    Is Nikosk fix for versions prior to v2.6 or do I have an older version of media-upload.js?

    Without this fix, I’m unable to add images to posts. Any help would be appreciated.

    Thanks, Joe

    I’m having this same problem on wp2.6.1, and have the same problem with “insert into post” –

    wish I could use nikosk’s suggested fix, but line six of my media-upload.js looks like:
    ed.selection.moveToBookmark(tinymce.EditorManager.activeEditor.windowManager.bookmark);

    Sadly I’m not too great with this stuff, but would muchly appreciate any tips. Right now, the insert into post button just gives me my site’s custom error page in the floating box.

    thanks!
    -jj

    Ok, so paying attention to this support thread:

    http://wordpress.org/support/topic/164999?replies=1

    solution #6, with mod_security ended up solving the problem…

    here’s the answer:

    mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:
    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
    That will disable mod_security for the upload file receiving code in the wp-admin directory.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘2.5 Image Insert Problem (not image upload)’ is closed to new replies.