WordPress.org

Support

Support » Plugins and Hacks » SendPress Newsletters » [Resolved] 0.9.9.4 Broken my website

[Resolved] 0.9.9.4 Broken my website

  • WordPress 3.8.1
    Sendpress 0.9.9.4

    I use sendpress without problem until I update the plugin to the recent update 0.9.9.4 and suddenly my admin dashboard cannot be access and get error saying,

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/xxxxxxxx/public_html/wp-content/plugins/sendpress/classes/class-sendpress-shortcode-loader.php on line 52

    I tried to find older version of sendpress in your website but cannot find older version. You should have them…

    What an you do to help?

    https://wordpress.org/plugins/sendpress/

Viewing 15 replies - 1 through 15 (of 20 total)
  • .9.4 breaks the front end of my site too (backend seems OK) and caused my hosting company to automatically restore a backup htaccess file. So not sure what’s going on there.

    You can find the older versions here:
    http://wordpress.org/plugins/sendpress/developers/

    I went back to .9.3 and it all seems fine.

    Plugin Author Josh Lyford

    @joshl

    Thanks for letting us know. We are looking into it.

    Best,
    Josh

    Plugin Author Josh Lyford

    @joshl

    HI DLT95,

    Could you tell me what version of php you are running?

    Thanks,
    Josh

    Plugin Author Josh Lyford

    @joshl

    We released 0.9.9.5 this will fix the issue you had. It was a conflict with PHP 5.2. You can also use this link to download the latest version.

    http://downloads.wordpress.org/plugin/sendpress.0.9.9.5.zip

    Best,
    Josh

    0.9.9.5 just broke my site I had to remove the update can I revert back without deleting database?

    Plugin Author Josh Lyford

    @joshl

    Hi ecitycreative,

    You can roll back to previous version. What did the update break? are you getting the Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM error? or something else.

    All older versions are on the developer tab for download. If you can provide any more info we can try and figure out what your issue is.

    Best,
    Josh

    I had the line 52 syntax error too, the wordPress admin function was broken so there was no way to login and update it. I had to delete the previous version and copy over the new version you posted above.

    I backed up my old wordpress folder but now I need help finding all my subscribers so I can re-install them into the database.

    Please Help!

    Plugin Author itdoug

    @itdoug

    Removing the plugin doesn’t delete anything from the database. Just check the subscribers tab and they should be there. The only way they could be missing is if you deleted your database or started over with a fresh install.

    I had to ftp into my website and delete the sendpress pluggin folde completely. That was the only way I could even get to the wp-admin login screen. I dowloaded a copy of the folder before I deleted it so are there any files I can copy back over with the subscribers intact? Thanks for you help.

    BroadRippleInc

    @broadrippleunlimited

    This isn’t much help or very descriptive, and tomorrow, I can reply with more info, but the latest Sendpress .95 (I think) has really broken every site I upgraded it on.

    I have rolled back to .93 to get Sendpress working again.

    I have similar problem. It looks like the fields are set to a specific width which is causing the widget to display outside the normal sidebar and thus messing up the layout of my site.

    Plugin Author itdoug

    @itdoug

    Several questions in this thread.

    First, the sendpress folder does not store any data. All data is in the database so you can safely delete or change the folder. Or reinstall later and your data will be there.

    .9.5 should resolve the upgrade issues. If you still have issues or specific problems we’ll try to help though. Provide the details here or in another forum topic. Please click the following link for instructions on what info to provide support. http://sendpress.com/support/knowledgebase/what-information-should-i-provide-in-a-support-ticket/

    3rd, widget issues can sometimes just be CSS related. Try going to settings > advanced and checking the CSS or other checkboxes. Alternatively you can use the form code in a text widget or the short code. There’s shortcode info on the help tab.

    Disregard my last post above. Apparently I had tweaked the code to work in my sidebar and had forgotten that so it messed it up when I overwrote the file with the new version.

    FYI …the shortcode is getting cut off so you cannot see it or copy it all. See screenshot below:
    http://www.leandertheatre.org/wp-content/uploads/screencap-1.jpg

    Sorry for the delay. My PHP version is 5.4 so I dont think my problem was caused by that.

    It’s a problem with the display of the right sidebar and reverting back to 9.9.3 fixes it. I cant really spend any time testing on the live server so I’ll just have to leave it.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] 0.9.9.4 Broken my website’ is closed to new replies.
Skip to toolbar